Bug 1552300 - Support webreplay subsuite in test-verify; r=bc
authorGeoff Brown <gbrown@mozilla.com>
Tue, 21 May 2019 13:26:09 +0000
changeset 474738 7b5f1a48d4e90a393618cd8e7302e22e7ea1d42b
parent 474737 8518f578b1636b86a817ba7307a9ed47c39a6548
child 474739 0339e62a0bc95a07f30db5de54c058c72bb0f8f5
push id36046
push useraiakab@mozilla.com
push dateTue, 21 May 2019 21:45:52 +0000
treeherdermozilla-central@257f2c96cef5 [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersbc
bugs1552300
milestone69.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1552300 - Support webreplay subsuite in test-verify; r=bc A new entry was required to map the subsuite name to the mozharness config name - simple! Differential Revision: https://phabricator.services.mozilla.com/D31522
testing/mozharness/mozharness/mozilla/testing/per_test_base.py
--- a/testing/mozharness/mozharness/mozilla/testing/per_test_base.py
+++ b/testing/mozharness/mozharness/mozilla/testing/per_test_base.py
@@ -135,16 +135,17 @@ class SingleTestMixin(FetchesMixin):
 
             self.info("Per-test run found test %s (%s/%s)" % (file, entry[0], entry[1]))
             subsuite_mapping = {
                 # Map (<suite>, <subsuite>): <full-suite>
                 #   <suite> is associated with a manifest, explicitly in code above
                 #   <subsuite> comes from "subsuite" tags in some manifest entries
                 #   <full-suite> is a unique id for the suite, matching desktop mozharness configs
                 ('mochitest-browser-chrome', 'devtools'): 'mochitest-devtools-chrome',
+                ('mochitest-browser-chrome', 'devtools-webreplay'): 'mochitest-devtools-chrome-webreplay', # noqa
                 ('mochitest-browser-chrome', 'screenshots'): 'mochitest-browser-chrome-screenshots',  # noqa
                 ('mochitest-plain', 'media'): 'mochitest-media',
                 # below should be on test-verify-gpu job
                 ('mochitest-chrome', 'gpu'): 'mochitest-chrome-gpu',
                 ('mochitest-plain', 'gpu'): 'mochitest-plain-gpu',
                 ('mochitest-plain', 'webgl1-core'): 'mochitest-webgl1-core',
                 ('mochitest-plain', 'webgl1-ext'): 'mochitest-webgl1-ext',
                 ('mochitest-plain', 'webgl2-core'): 'mochitest-webgl2-core',