Bug 1628755 - Fix test_ext_privacy.js xpcshell-test failure in beta, r=mixedpuppy
authorAndrea Marchesini <amarchesini@mozilla.com>
Tue, 28 Apr 2020 17:38:51 +0000
changeset 526542 7013b18788c1b6f516af9a100f3573f02723263b
parent 526541 c4a72c937045df517cbcb8e02307245bbbbe35b9
child 526543 70fe927b2a53b6236972f50f16a81681063e3589
push id37358
push useropoprus@mozilla.com
push dateWed, 29 Apr 2020 03:05:14 +0000
treeherdermozilla-central@6bb8423186c1 [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersmixedpuppy
bugs1628755
milestone77.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1628755 - Fix test_ext_privacy.js xpcshell-test failure in beta, r=mixedpuppy Differential Revision: https://phabricator.services.mozilla.com/D72810
toolkit/components/extensions/test/xpcshell/test_ext_privacy.js
--- a/toolkit/components/extensions/test/xpcshell/test_ext_privacy.js
+++ b/toolkit/components/extensions/test/xpcshell/test_ext_privacy.js
@@ -779,21 +779,21 @@ add_task(async function test_privacy_oth
     "Setting TLS max version lower than the min version is not allowed."
   );
 
   // Empty value.
   await testSetting(
     "network.tlsVersionRestriction",
     {},
     {
-      "security.tls.version.min": 3,
+      "security.tls.version.min": tlsMinPref,
       "security.tls.version.max": 4,
     },
     {
-      minimum: "TLSv1.2",
+      minimum: tlsMinVer,
       maximum: "TLSv1.3",
     }
   );
 
   await extension.unload();
 
   await promiseShutdownManager();
 });