Backed out changeset ac23ad5ef0c1 (bug 1542862) as requested by glandium for being obsolete after bug 1536486.
authorCosmin Sabou <csabou@mozilla.com>
Fri, 12 Apr 2019 02:24:21 +0300
changeset 469122 6826a3ede4cab76cf3a9a9d2f94a0ac8252c6cf7
parent 469121 236d2bc601b0604b30e03b2e61a50a3886961edb
child 469123 529a9a8efae1411d6e858da014db27a48f235b4b
push id35856
push usercsabou@mozilla.com
push dateFri, 12 Apr 2019 03:19:48 +0000
treeherdermozilla-central@940684cd1065 [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
bugs1542862, 1536486
milestone68.0a1
backs outac23ad5ef0c18d7bf5b55fd9d07cfd1c0da33033
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Backed out changeset ac23ad5ef0c1 (bug 1542862) as requested by glandium for being obsolete after bug 1536486.
build/moz.configure/rust.configure
--- a/build/moz.configure/rust.configure
+++ b/build/moz.configure/rust.configure
@@ -95,19 +95,19 @@ def cargo_info(cargo):
             die('Could not determine cargo version from output: %s', out)
         version = m.group(1)
 
     return namespace(
         version=Version(version),
     )
 
 
-@depends(rustc_info, cargo_info, build_project, host, target)
+@depends(rustc_info, cargo_info, build_project)
 @imports(_from='textwrap', _import='dedent')
-def rust_compiler(rustc_info, cargo_info, build_project, host, target):
+def rust_compiler(rustc_info, cargo_info, build_project):
     if not rustc_info:
         die(dedent('''\
         Rust compiler not found.
         To compile rust language sources, you must have 'rustc' in your path.
         See https://www.rust-lang.org/ for more information.
 
         You can install rust by running './mach bootstrap'
         or by directly running the installer from https://rustup.rs/
@@ -130,24 +130,16 @@ def rust_compiler(rustc_info, cargo_info
 
         You can verify this by typing 'rustc --version'.
 
         If you have the 'rustup' tool installed you can upgrade
         to the latest release by typing 'rustup update'. The
         installer is available from https://rustup.rs/
         '''.format(version, rustc_min_version)))
 
-    if host.os == 'OSX' and target.os == 'Android' and version >= '1.33.0':
-        die(dedent('''\
-        Cross-Compiling Android on OSX with Rust 1.33 is currently broken, see bug 1536486.
-
-        As a workaround: invoke 'rustup override set 1.32.0' in your source directory, then
-        rerun './mach bootstrap' to pick up the required toolchains.
-        '''))
-
     if not cargo_info:
         die(dedent('''\
         Cargo package manager not found.
         To compile Rust language sources, you must have 'cargo' in your path.
         See https://www.rust-lang.org/ for more information.
 
         You can install cargo by running './mach bootstrap'
         or by directly running the installer from https://rustup.rs/