Bug 1024238 - Die in configure if building with less than SDK 19. r=nalexander
authorRichard Newman <rnewman@mozilla.com>
Wed, 11 Jun 2014 17:36:33 -0700
changeset 188329 35668b465d00daf983dfb012b99ca301b5708cbb
parent 188328 4ed277e051da1e90e3065f744d524386746b3e8f
child 188330 abfe8ef3a851249b32542b3575db3e6a5ed90f90
push id26951
push useremorley@mozilla.com
push dateThu, 12 Jun 2014 14:07:43 +0000
treeherdermozilla-central@4f98802de6ce [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersnalexander
bugs1024238
milestone33.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1024238 - Die in configure if building with less than SDK 19. r=nalexander
configure.in
--- a/configure.in
+++ b/configure.in
@@ -4161,24 +4161,24 @@ AC_SUBST(MOZ_PHOENIX)
 AC_SUBST(MOZ_XULRUNNER)
 AC_SUBST(MOZ_B2G)
 AC_SUBST(MOZ_MULET)
 AC_SUBST(MOZ_B2G_VERSION)
 
 AC_DEFINE_UNQUOTED(MOZ_BUILD_APP,$MOZ_BUILD_APP)
 
 dnl ========================================================
-dnl Check android sdk version depending on mobile target
+dnl Check Android SDK version depending on mobile target.
 dnl ========================================================
 
 if test -z "$gonkdir" ; then
     # Minimum Android SDK API Level we require.
     case "$MOZ_BUILD_APP" in
     mobile/android)
-        android_min_api_level=16
+        android_min_api_level=17
         case "$target" in
         *-android*|*-linuxandroid*)
             :
             ;;
         *)
             AC_MSG_ERROR([You must specify --target=arm-linux-androideabi (or some other valid android target) when building with --enable-application=mobile/android. See https://wiki.mozilla.org/Mobile/Fennec/Android#Setup_Fennec_mozconfig for more information about the necessary options])
             ;;
         esac