Bug 1430934 - mozboot: Update to rust 1.23.0. r=nalexander
authorRalph Giles <giles@mozilla.com>
Tue, 16 Jan 2018 15:07:14 -0800
changeset 400797 00c89c0a33d1691c7bfc979eb344e576145bc256
parent 400796 798e1d210015c51eeeb495ce0cd0a39ec4fd24d8
child 400798 c25d4fc1b17e6953c1526760f92366f98bb055ce
child 400864 33893b1ab9857d7edb0622d61e5277ae220d6535
push id33318
push useraiakab@mozilla.com
push dateFri, 26 Jan 2018 00:17:50 +0000
treeherdermozilla-central@c25d4fc1b17e [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersnalexander
bugs1430934
milestone60.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1430934 - mozboot: Update to rust 1.23.0. r=nalexander Have `./mach boostrap` update users to at least rust 1.23.0, which is the current stable release. MozReview-Commit-ID: 7ukx7shu07e
python/mozboot/mozboot/base.py
--- a/python/mozboot/mozboot/base.py
+++ b/python/mozboot/mozboot/base.py
@@ -145,17 +145,17 @@ ac_add_options --enable-artifact-builds
 # This should match OLDEST_NON_LEGACY_VERSION from
 # the hg setup wizard in version-control-tools.
 MODERN_MERCURIAL_VERSION = LooseVersion('4.2.3')
 
 # Upgrade Python older than this.
 MODERN_PYTHON_VERSION = LooseVersion('2.7.3')
 
 # Upgrade rust older than this.
-MODERN_RUST_VERSION = LooseVersion('1.22.0')
+MODERN_RUST_VERSION = LooseVersion('1.23.0')
 
 
 class BaseBootstrapper(object):
     """Base class for system bootstrappers."""
 
     def __init__(self, no_interactive=False):
         self.package_manager_updated = False
         self.no_interactive = no_interactive