195c5c599588: Bug 1274729 - corrupted content string management r=dragana
Patrick McManus <mcmanus@ducksong.com> - Mon, 23 May 2016 10:12:31 -0400 - rev 298786
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
Bug 1274729 - corrupted content string management r=dragana
a73b559073f5: Bug 1215319 - zip archive fix part 2 r=dragana
Patrick McManus <mcmanus@ducksong.com> - Mon, 23 May 2016 17:06:44 -0400 - rev 298785
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
Bug 1215319 - zip archive fix part 2 r=dragana
f37493706dd7: Bug 1233679 - UpdateTestcase should remove any partially downloaded update. r=maja_zf
Henrik Skupin <mail@hskupin.info> - Tue, 24 May 2016 12:14:59 +0200 - rev 298784
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
Bug 1233679 - UpdateTestcase should remove any partially downloaded update. r=maja_zf MozReview-Commit-ID: FpKDcElYF7L
011e172a9ddf: Bug 1275249 - Update UI tests to get property where applicable; r=whimboo
Andreas Tolfsen <ato@mozilla.com> - Tue, 24 May 2016 14:26:13 +0100 - rev 298783
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
Bug 1275249 - Update UI tests to get property where applicable; r=whimboo In bug 1272653, Get Element Attribute was split into Get Element Attribute for attributes and boolean attributes, and Get Element Property for properties. This patch addresses the fallout in the Firefox UI tests caused by those patches. MozReview-Commit-ID: 9S4epjmpU0o
7562ee87e961: Bug 1272599 part.2 Rename KeyboardEvent.key values, "MozHomeScreen" and "MozCameraFocusAdjust" to "GoHome" and "CameraFocus" except on B2G r=smaug
Masayuki Nakano <masayuki@d-toybox.com> - Fri, 20 May 2016 21:29:10 +0900 - rev 298782
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
Bug 1272599 part.2 Rename KeyboardEvent.key values, "MozHomeScreen" and "MozCameraFocusAdjust" to "GoHome" and "CameraFocus" except on B2G r=smaug KEYCODE_HOME was temporarily named as "MozHomeScreen" and KEYCODE_FOCUS was temprarily named as "MozCameraFocusAdjust" since they were not defined by the spec. However, in the latest spec, they are defined as "GoHome" and "CameraFocus". So, it is the time to rename them. However, these temporary key names are still used by Gaia. Until it's fixed, we should keep using the temporary names only on B2G. MozReview-Commit-ID: 9ILtZdf6EUQ
d50ff85ea0db: Bug 1272599 part.1 Rename KeyboardEvent.key value, "MozPhoneCall" to "Call" r=smaug
Masayuki Nakano <masayuki@d-toybox.com> - Fri, 20 May 2016 21:00:20 +0900 - rev 298781
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
Bug 1272599 part.1 Rename KeyboardEvent.key value, "MozPhoneCall" to "Call" r=smaug Android's KEYCODE_CALL was temporarily named as "MozPhoneCall" since proper key name was not defined in the spec. However, now, it's defined as "Call" in the latest spec. Therefore, we should rename this key name. Note that this isn't available on Android because the key event is never fired on applications. However, this key may be useful on B2G. Although, the key is not used by current Gaia. MozReview-Commit-ID: GF4STYrGMig
cfaea09ca341: Bug 1272578 part.3 Rename key name VolumeMute to AudioVolumeMute except on B2G r=smaug
Masayuki Nakano <masayuki@d-toybox.com> - Sat, 21 May 2016 00:57:18 +0900 - rev 298780
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
Bug 1272578 part.3 Rename key name VolumeMute to AudioVolumeMute except on B2G r=smaug VolumeMute was renamed to AudioVolumeMute in the latest draft and Chromium uses the new name. Therefore, we need to update this but Gaia uses the old name. So, we shouldn't rename on B2G until Gaia is fixed. Note that this patch changes tests but they are not used by B2G. Therefore, just replacing with new name is enough. Only forms.js is necessary #ifdef because the main purpose of forms.js is for B2G's IME framework. However, it's available on the other platforms if chrome needs to use it. MozReview-Commit-ID: KSkcPbIovin
8e106633b86e: Bug 1272578 part.2 Rename key name VolumeUp to AudioVolumeUp except on B2G r=smaug
Masayuki Nakano <masayuki@d-toybox.com> - Sat, 21 May 2016 00:55:48 +0900 - rev 298779
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
Bug 1272578 part.2 Rename key name VolumeUp to AudioVolumeUp except on B2G r=smaug VolumeUp was renamed to AudioVolumeUp in the latest draft and Chromium uses the new name. Therefore, we need to update this but Gaia uses the old name. So, we shouldn't rename on B2G until Gaia is fixed. Note that this patch changes tests but they are not used by B2G. Therefore, just replacing with new name is enough. Only forms.js is necessary #ifdef because the main purpose of forms.js is for B2G's IME framework. However, it's available on the other platforms if chrome needs to use it. MozReview-Commit-ID: KzLVL5Y2dIN
d0604395964c: Bug 1272578 part.1 Rename key name VolumeDown to AudioVolumeDown except on B2G r=smaug
Masayuki Nakano <masayuki@d-toybox.com> - Sat, 21 May 2016 00:52:03 +0900 - rev 298778
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
Bug 1272578 part.1 Rename key name VolumeDown to AudioVolumeDown except on B2G r=smaug VolumeDown was renamed to AudioVolumeDown in the latest draft and Chromium uses the new name. Therefore, we need to update this but Gaia uses the old name. So, we shouldn't rename on B2G until Gaia is fixed. Note that this patch changes tests but they are not used by B2G. Therefore, just replacing with new name is enough. Only forms.js is necessary #ifdef because the main purpose of forms.js is for B2G's IME framework. However, it's available on the other platforms if chrome needs to use it. MozReview-Commit-ID: cq98qJnS8M
f02ee7dd94e0: Merge mozilla-central to mozilla-inbound
Carsten "Tomcat" Book <cbook@mozilla.com> - Tue, 24 May 2016 15:13:51 +0200 - rev 298777
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
Merge mozilla-central to mozilla-inbound
b0a487d7e8e4: No Bug - Remove some dead imgLoader code from nsContentUtils.h. r=me
Jonathan Watt <jwatt@jwatt.org> - Wed, 18 May 2016 21:24:16 +0100 - rev 298776
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
No Bug - Remove some dead imgLoader code from nsContentUtils.h. r=me
472fd2e0cf31: Bug 1274193 part 10 - Use GO_THROUGH_SAVED in JS::GetScriptedCallerGlobal. r=luke
Jan de Mooij <jdemooij@mozilla.com> - Tue, 24 May 2016 14:38:34 +0200 - rev 298775
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
Bug 1274193 part 10 - Use GO_THROUGH_SAVED in JS::GetScriptedCallerGlobal. r=luke
8fa9dceab5e6: Bug 1274193 part 9 - Do principal filtering in DescribeScriptedCallerForCompilation and use GO_THROUGH_SAVED. r=luke
Jan de Mooij <jdemooij@mozilla.com> - Tue, 24 May 2016 14:38:34 +0200 - rev 298774
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
Bug 1274193 part 9 - Do principal filtering in DescribeScriptedCallerForCompilation and use GO_THROUGH_SAVED. r=luke
ee7ad0668921: Bug 1274193 part 8 - Use GO_THROUGH_SAVED for fun.caller/fun.arguments. r=luke
Jan de Mooij <jdemooij@mozilla.com> - Tue, 24 May 2016 14:38:34 +0200 - rev 298773
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
Bug 1274193 part 8 - Use GO_THROUGH_SAVED for fun.caller/fun.arguments. r=luke
faa07a14d470: Bug 1274193 part 7 - Use GO_THROUGH_SAVED in rollbackPartiallyInitializedObjects and ReportIncompatibleSelfHostedMethod. r=luke
Jan de Mooij <jdemooij@mozilla.com> - Tue, 24 May 2016 14:38:27 +0200 - rev 298772
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
Bug 1274193 part 7 - Use GO_THROUGH_SAVED in rollbackPartiallyInitializedObjects and ReportIncompatibleSelfHostedMethod. r=luke
701378e19df1: Bug 1274193 part 6 - Use GO_THROUGH_SAVED for the expression decompiler. r=jorendorff
Jan de Mooij <jdemooij@mozilla.com> - Tue, 24 May 2016 14:31:45 +0200 - rev 298771
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
Bug 1274193 part 6 - Use GO_THROUGH_SAVED for the expression decompiler. r=jorendorff
3908a77903cf: Bug 1274612 - Fix static analysis build errors caused by missing explicit keyword r=me
Jon Coppeard <jcoppeard@mozilla.com> - Tue, 24 May 2016 13:26:06 +0100 - rev 298770
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
Bug 1274612 - Fix static analysis build errors caused by missing explicit keyword r=me
a9b9a9115d01: Bug 1274765: Upgrade mercurial on docker images. r=garndt
Wander Lairson Costa <wcosta@mozilla.com> - Mon, 23 May 2016 10:45:00 +0200 - rev 298769
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
Bug 1274765: Upgrade mercurial on docker images. r=garndt Instead of using mockbuilds-repo to install mercurial, we do so through pip.
1fe1c3b03d08: Bug 890908 - "Move Negotiate auth off main thread". r=mayhemer
Jan Horak <jhorak@redhat.com> - Fri, 20 May 2016 06:07:00 +0200 - rev 298768
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
Bug 890908 - "Move Negotiate auth off main thread". r=mayhemer
3a7ba1ce51d6: Bug 1275033 - Optimise global object write barrier r=jandem
Jon Coppeard <jcoppeard@mozilla.com> - Tue, 24 May 2016 12:39:26 +0100 - rev 298767
Push 30285 by cbook@mozilla.com at Wed, 25 May 2016 13:06:07 +0000
Bug 1275033 - Optimise global object write barrier r=jandem
(0) -100000 -30000 -10000 -3000 -1000 -300 -100 -50 -20 +20 +50 +100 +300 +1000 +3000 +10000 +30000 +100000 tip