remote/test/puppeteer/package.json
author moz-wptsync-bot <wptsync@mozilla.com>
Thu, 02 Feb 2023 17:56:40 +0000
changeset 651741 193873a769705e43125bf048e01f18ac964d91b4
parent 650810 fed0f8debc36b8042b7d9aece965e1b8f334208a
permissions -rw-r--r--
Bug 1814704 - [wpt-sync] Update web-platform-tests to cfdf7a3b7129de7f29c9ff9e9d63a4cfb56696fd, a=testonly MANUAL PUSH: wpt sync bot wpt-head: cfdf7a3b7129de7f29c9ff9e9d63a4cfb56696fd wpt-type: landing

{
  "name": "puppeteer-repo",
  "private": true,
  "repository": {
    "type": "git",
    "url": "https://github.com/puppeteer/puppeteer"
  },
  "scripts": {
    "bisect": "tsx tools/bisect.ts",
    "build": "npm run build --workspaces --if-present",
    "check:pinned-deps": "tsx tools/ensure-pinned-deps",
    "check": "npm run check --workspaces --if-present && run-p check:*",
    "clean": "npm run clean --workspaces --if-present && rimraf **/.wireit",
    "commitlint": "commitlint --from=HEAD~1",
    "debug": "mocha --inspect-brk",
    "docs": "run-s build generate:markdown",
    "format:eslint": "eslint --ext js --ext ts --fix .",
    "format:prettier": "prettier --write .",
    "format": "run-s format:*",
    "generate:markdown": "tsx tools/generate_docs.ts",
    "lint:eslint": "([ \"$CI\" = true ] && eslint --ext js --ext ts --quiet -f codeframe . || eslint --ext js --ext ts .)",
    "lint:prettier": "prettier --check .",
    "lint": "run-s lint:prettier lint:eslint",
    "postinstall": "npm run postinstall --workspaces --if-present",
    "prepare": "husky install",
    "test-install": "npm run test --workspace @puppeteer-test/installation",
    "test-types": "tsd -t packages/puppeteer",
    "test:chrome:headful": "npm test -- --test-suite chrome-headful",
    "test:chrome:headless-chrome": "npm test -- --test-suite chrome-new-headless",
    "test:chrome:headless": "npm test -- --test-suite chrome-headless",
    "test:chrome:bidi": "npm test -- --test-suite chrome-bidi",
    "test:chrome": "run-s test:chrome:*",
    "test:firefox:bidi": "npm test -- --test-suite firefox-bidi",
    "test:firefox:headful": "npm test -- --test-suite firefox-headful",
    "test:firefox:headless": "npm test -- --test-suite firefox-headless",
    "test:firefox": "run-s test:firefox:*",
    "test": "cross-env PUPPETEER_DEFERRED_PROMISE_DEBUG_TIMEOUT=20000 node tools/mochaRunner/lib/main.js"
  },
  "devDependencies": {
    "@actions/core": "1.10.0",
    "@commitlint/cli": "17.3.0",
    "@commitlint/config-conventional": "17.3.0",
    "@microsoft/api-documenter": "7.19.26",
    "@microsoft/api-extractor": "7.33.7",
    "@microsoft/api-extractor-model": "7.25.3",
    "@pptr/testserver": "file:packages/testserver",
    "@rollup/plugin-commonjs": "24.0.0",
    "@rollup/plugin-node-resolve": "15.0.1",
    "@types/debug": "4.1.7",
    "@types/diff": "5.0.2",
    "@types/glob": "8.0.0",
    "@types/mime": "3.0.1",
    "@types/mocha": "10.0.1",
    "@types/node": "18.11.17",
    "@types/pixelmatch": "5.2.4",
    "@types/pngjs": "6.0.1",
    "@types/progress": "2.0.5",
    "@types/proxy-from-env": "1.0.1",
    "@types/rimraf": "3.0.2",
    "@types/semver": "7.3.13",
    "@types/sinon": "10.0.13",
    "@types/tar-fs": "2.0.1",
    "@types/unbzip2-stream": "1.4.0",
    "@types/ws": "8.5.3",
    "@typescript-eslint/eslint-plugin": "5.46.1",
    "@typescript-eslint/parser": "5.46.1",
    "c8": "7.12.0",
    "chromium-bidi": "0.4.3",
    "commonmark": "0.30.0",
    "cross-env": "7.0.3",
    "diff": "5.1.0",
    "esbuild": "0.16.9",
    "eslint": "8.30.0",
    "eslint-config-prettier": "8.5.0",
    "eslint-formatter-codeframe": "7.32.1",
    "eslint-plugin-import": "2.26.0",
    "eslint-plugin-local": "1.0.0",
    "eslint-plugin-mocha": "10.1.0",
    "eslint-plugin-prettier": "4.2.1",
    "eslint-plugin-tsdoc": "0.2.17",
    "eslint-plugin-unused-imports": "2.0.0",
    "esprima": "4.0.1",
    "expect": "25.2.7",
    "glob": "8.1.0",
    "gts": "4.0.0",
    "husky": "8.0.2",
    "jpeg-js": "0.4.4",
    "mime": "3.0.0",
    "minimist": "1.2.7",
    "mitt": "3.0.0",
    "mocha": "10.2.0",
    "ncp": "2.0.0",
    "npm-run-all": "4.1.5",
    "pixelmatch": "5.3.0",
    "pngjs": "6.0.0",
    "prettier": "2.8.1",
    "puppeteer": "file:packages/puppeteer",
    "rollup": "2.79.1",
    "rollup-plugin-dts": "4.2.2",
    "semver": "7.3.8",
    "sinon": "15.0.1",
    "source-map-support": "0.5.21",
    "text-diff": "1.0.1",
    "tsd": "0.25.0",
    "tsx": "3.12.1",
    "typescript": "4.9.4",
    "wireit": "0.9.2",
    "zod": "3.20.2"
  },
  "workspaces": [
    "packages/*",
    "test",
    "test/installation"
  ]
}