gradle.properties
author Andrew Halberstadt <ahalberstadt@mozilla.com>
Tue, 30 Aug 2016 14:28:56 -0400
changeset 311990 f5c7a3d60bd9498b63f94faefad4f4e3f1205175
parent 269585 b39a7e4289d8de57151b826dec3902130f9d0634
child 386778 fff0a54320b0cd3924790f744f93533bfd386b1e
permissions -rw-r--r--
Bug 1258341 - Modify 'eslint' implementation to work with the mozlint framework, r=smacleod This integrates 'eslint' with the mozlint framework. The old |mach eslint| command is kept around for backwards compatibility and will simply dispatch to |mach lint|. But |mach lint| should be preferred as the old command may eventually be removed. The old |mach eslint| command should be mostly backwards compatible with a few exceptions: 1. Can no longer define --extensions on the command line, this is instead hardcoded into eslint.lint. 2. No longer using eslint formatters. However, the default mozlint formatter should be identical to the default eslint formatter, so developers should not notice a change. This does mean that non-default eslint formatters can no longer be used unless a mozlint copy of them is created. 3. Installs dependencies automatically without prompting the user. This was necessary due to python multiprocessing limitations, but is actually also a better UX. Because the npm dependencies aren't global anymore, there isn't really any reason *not* to install them automatically. Apart from that, any difference from the old |mach eslint| I'd consider a bug. The main eslint implementation now lives in tools/lint/eslint.lint instead of tools/lint/mach_commands.py. MozReview-Commit-ID: KYhC6SEySC3

org.gradle.parallel=true
org.gradle.daemon=true