python/mozboot/mozboot/openbsd.py
author Mike Hommey <mh+mozilla@glandium.org>
Wed, 22 Jul 2015 10:39:41 +0900
changeset 254242 05f6b5bc5b4b53bdcd7781946b89be3867de33d8
parent 240717 5da7e0d7f32e1b065ad9de57867425ee35ab6343
child 277384 e1dd3b46edf03a2005c1e440f9b11159507629db
permissions -rw-r--r--
Bug 1186229 - Enable Gtk+3 builds by default. r=gps Note Gtk+3 builds need both Gtk+2 *and* Gtk+3.

# This Source Code Form is subject to the terms of the Mozilla Public
# License, v. 2.0. If a copy of the MPL was not distributed with this file,
# You can obtain one at http://mozilla.org/MPL/2.0/.

from mozboot.base import BaseBootstrapper


class OpenBSDBootstrapper(BaseBootstrapper):
    def __init__(self, version, **kwargs):
        BaseBootstrapper.__init__(self, **kwargs)

        self.packages = [
            'mercurial',
            'autoconf-2.13',
            'gmake',
            'gtar',
            'wget',
            'unzip',
            'zip',
        ]

        self.browser_packages = [
            'llvm',
            'yasm',
            'gtk+2',
            'gtk+3',
            'dbus-glib',
            'gstreamer-plugins-base',
            'pulseaudio',
        ]

    def install_system_packages(self):
        # we use -z because there's no other way to say "any autoconf-2.13"
        self.run_as_root(['pkg_add', '-z'] + self.packages)

    def install_browser_packages(self):
        # we use -z because there's no other way to say "any autoconf-2.13"
        self.run_as_root(['pkg_add', '-z'] + self.browser_packages)