Remove import of auth.js, which is now contained in resource since beta 10.
authorEdward Lee <edilee@mozilla.com>
Thu, 17 Feb 2011 13:57:01 -0800
changeset 27 2b1a6899a4b010fbd22d8844d6571e378969aec7
parent 26 25e9cd40edd6b52c22fe12c239e3098f41cb5d8f
child 28 1260edd54f2e5cae0e0bf9baa31c415afcfba26c
push id26
push useredward.lee@engineering.uiuc.edu
push dateThu, 17 Feb 2011 22:03:37 +0000
Remove import of auth.js, which is now contained in resource since beta 10.
bootstrap.js
install.rdf
--- a/bootstrap.js
+++ b/bootstrap.js
@@ -429,17 +429,16 @@ function preparePeriodicUpdates() {
   checker();
   unloaders.push(function() checker.timer.clear());
 }
 
 /**
  * Handle the add-on being activated on install/enable
  */
 function startup(data, reason) AddonManager.getAddonByID(data.id, function(addon) {
-  Cu.import("resource://services-sync/auth.js");
   Cu.import("resource://services-sync/ext/Preferences.js");
   Cu.import("resource://services-sync/resource.js");
   Cu.import("resource://services-sync/util.js");
 
   if (reason == ADDON_ENABLE)
     enableDisabled();
 
   observeAddonUpdates();
--- a/install.rdf
+++ b/install.rdf
@@ -11,14 +11,14 @@
     <version>2</version>
 
     <bootstrap>true</bootstrap>
     <type>2</type>
 
     <targetApplication>
       <r:Description>
         <id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</id>
-        <minVersion>4.0b6</minVersion>
-        <maxVersion>4.0b9pre</maxVersion>
+        <minVersion>4.0b10</minVersion>
+        <maxVersion>4.0.*</maxVersion>
       </r:Description>
     </targetApplication>
   </r:Description>
 </r:RDF>