Bug 1528219 - Display explicit non-backward message when trying to connect from 67 to older version r=daisuke,loganfsmyth
authorJulian Descottes <jdescottes@mozilla.com>
Sat, 09 Mar 2019 00:59:03 +0000
changeset 11202 e796587b41190a18cec70e53f88792f944e446c6
parent 11201 2262407d4961760eaa53635043242997eda9cfea
child 11203 464befb8d29125228a2edc89fbf1374e26040f0e
push id121
push userflodolo@mozilla.com
push dateTue, 12 Mar 2019 09:38:15 +0000
reviewersdaisuke, loganfsmyth
bugs1528219
Bug 1528219 - Display explicit non-backward message when trying to connect from 67 to older version r=daisuke,loganfsmyth Differential Revision: https://phabricator.services.mozilla.com/D19939 X-Channel-Repo: mozilla-central X-Channel-Converted-Revision: 3e43e15218d95eecc53546fe299373826cc66aaa X-Channel-Repo: releases/mozilla-beta X-Channel-Revision: 6dd6bcd4c1427c0c7d0e8b7e66c7f5a55143cd34 X-Channel-Repo: releases/mozilla-release X-Channel-Revision: c2fca1944d8c54d01a5e2d7e13d965e4a6597307
devtools/client/webide.properties
--- a/devtools/client/webide.properties
+++ b/devtools/client/webide.properties
@@ -46,16 +46,25 @@ error_appProjectsLoadFailed=Unable to load project list. This can occur if you’ve used this profile with a newer version of Firefox.
 error_folderCreationFailed=Unable to create project folder in the selected directory.
 
 # Variable: runtime app build ID (looks like this %Y%M%D format) and firefox build ID (same format)
 error_runtimeVersionTooRecent=The connected runtime has a more recent build date (%1$S) than your desktop Firefox (%2$S) does. This is an unsupported setup and may cause DevTools to fail. Please update Firefox.
 
 # Variable: runtime app version (looks like this 52.a3) and firefox version (same format)
 error_runtimeVersionTooOld=The connected runtime has an old version (%1$S). The minimum supported version is (%2$S). This is an unsupported setup and may cause DevTools to fail. Please update the connected runtime.
 
+# LOCALIZATION NOTE (error_runtimeVersionTooOld67Debugger): Dedicated message
+# for a backward compatibility issue that occurs when connecting:
+# - from Fx 67 to 66 or to 65
+# - from Fx 68 to 66
+# Those are normally in range for DevTools compatibility policy, but specific non
+# backward compatible changes broke the debugger in those scenarios (Bug 1528219).
+# Variable: runtime app version (looks like this 52.a3)
+error_runtimeVersionTooOld67Debugger=The Debugger panel may not work with the connected runtime. Please use Firefox %S if you need to use the Debugger with this runtime.
+
 addons_stable=stable
 addons_unstable=unstable
 addons_install_button=install
 addons_uninstall_button=uninstall
 addons_adb_warning=USB devices won’t be detected without this add-on
 addons_status_unknown=?
 addons_status_installed=Installed
 addons_status_uninstalled=Not Installed