Bug 1103825 - Documents libs requirements for platform.ini; r=mshal
authorGregory Szorc <gps@mozilla.com>
Sun, 23 Nov 2014 20:36:57 -0800
changeset 217517 67444e68593e95ffb20bbf0f512f03c485ca5f72
parent 217516 bb5f6f26f3a18df416642cd8fd583c3fc8e5ae13
child 217518 7cbe50231e185df44fe5afd3e13638be2fab9d6a
push id52299
push usergszorc@mozilla.com
push dateWed, 26 Nov 2014 01:28:07 +0000
treeherdermozilla-inbound@69f755d4f257 [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersmshal
bugs1103825
milestone36.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1103825 - Documents libs requirements for platform.ini; r=mshal While trying to port platform.ini to the misc tier, it was discovered that moving it out of libs breaks packaging. Document this.
toolkit/xre/Makefile.in
--- a/toolkit/xre/Makefile.in
+++ b/toolkit/xre/Makefile.in
@@ -42,10 +42,11 @@ DEFINES += -DGRE_BUILDID=$(GRE_BUILDID)
 
 $(srcdir)/nsAppRunner.cpp: $(DEPTH)/config/buildid $(milestone_txt)
 
 platform.ini: FORCE
 	$(PYTHON) $(srcdir)/make-platformini.py --buildid=$(GRE_BUILDID) $(INIARGS) $(milestone_txt) > $@
 
 GARBAGE += platform.ini
 
+# Moving this out of libs breaks packaging.
 libs:: platform.ini
 	$(INSTALL) $^ $(DIST)/bin