package.json
author Agi Sferro <agi@mozilla.com>
Mon, 17 Dec 2018 22:32:11 +0000
changeset 451061 42f4f1c36ef6daf56fae1433db40a3116b3dfe9d
parent 439070 4ef2bffa13bc7ff2cea3a7c65c55718c0bcc8847
child 452596 4b0da3a2a9facebc598079ca6e8161cefb3448ea
permissions -rw-r--r--
Bug 1502118 - Enforce GV lints with apilint. r=snorp This makes it so that apilints lints with "GV" codes are enforced and will fail the build. Depends on D13882 Differential Revision: https://phabricator.services.mozilla.com/D13883

{
  "name": "mozilla-central",
  "description": "This package file is for node modules used in mozilla-central",
  "repository": {},
  "license": "MPL-2.0",
  "dependencies": {},
  "devDependencies": {
    "eslint": "5.6.0",
    "eslint-plugin-html": "4.0.6",
    "eslint-plugin-mozilla": "file:tools/lint/eslint/eslint-plugin-mozilla",
    "eslint-plugin-no-unsanitized": "3.0.2",
    "eslint-plugin-react": "7.11.1",
    "eslint-plugin-spidermonkey-js": "file:tools/lint/eslint/eslint-plugin-spidermonkey-js"
  },
  "notes(private)": "We don't want to publish to npm, so this is marked as private",
  "private": true
}