Bug 1300866 - expose devtools require to new debugger r=jlast,bgrins
authorJames Long <longster@gmail.com>
Tue, 06 Sep 2016 17:17:35 -0400
changeset 312816 ae2144aa4356b65c2f8c0de8c9082dcb7e330e24
parent 312815 37c9349b4e8167a61b08b7e119c21ea177b98942
child 312850 73a6a267a50a0e1c41e689b265ad3eebe43d7ac6
push id20465
push userjlong@mozilla.com
push dateTue, 06 Sep 2016 21:18:16 +0000
treeherderfx-team@ae2144aa4356 [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersjlast, bgrins
bugs1300866
milestone51.0a1
Bug 1300866 - expose devtools require to new debugger r=jlast,bgrins
devtools/client/debugger/new/index.html
--- a/devtools/client/debugger/new/index.html
+++ b/devtools/client/debugger/new/index.html
@@ -3,11 +3,14 @@
    - file, You can obtain one at http://mozilla.org/MPL/2.0/. -->
 <!DOCTYPE html>
 <html>
   <head>
     <link rel="stylesheet" type="text/css" href="resource://devtools/client/debugger/new/styles.css" />
   </head>
   <body>
     <div id="mount"></div>
+    <script type="text/javascript">
+      var devtoolsRequire = Components.utils.import("resource://devtools/shared/Loader.jsm", {}).require;
+    </script>
     <script type="text/javascript" src="resource://devtools/client/debugger/new/bundle.js"></script>
   </body>
 </html>