Bug 1186233 - Set test_packages_url correctly when running wpt from mozharness but outside of buildbot. r=jgraham
authorChris Manchester <cmanchester@mozilla.com>
Tue, 21 Jul 2015 15:27:30 -0700
changeset 254638 59f70ba8d1ab732b945ba2c7db8489103d62bc9d
parent 254637 a983b06b1be393b73b6aef5cb2a2b6729145633e
child 254639 b1165227cd7382daa11a01257f8214f8df72656d
push id14246
push userryanvm@gmail.com
push dateMon, 27 Jul 2015 14:44:11 +0000
treeherderfx-team@c2e8b03c28bc [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersjgraham
bugs1186233
milestone42.0a1
Bug 1186233 - Set test_packages_url correctly when running wpt from mozharness but outside of buildbot. r=jgraham
testing/mozharness/scripts/web_platform_tests.py
--- a/testing/mozharness/scripts/web_platform_tests.py
+++ b/testing/mozharness/scripts/web_platform_tests.py
@@ -52,16 +52,17 @@ class WebPlatformTest(TestingMixin, Merc
             ],
             require_config_file=require_config_file,
             config={'require_test_zip': True})
 
         # Surely this should be in the superclass
         c = self.config
         self.installer_url = c.get('installer_url')
         self.test_url = c.get('test_url')
+        self.test_packages_url = c.get('test_packages_url')
         self.installer_path = c.get('installer_path')
         self.binary_path = c.get('binary_path')
         self.abs_app_dir = None
 
     def query_abs_app_dir(self):
         """We can't set this in advance, because OSX install directories
         change depending on branding and opt/debug.
         """