Bug 1257870 - Require 1.5.0 --with-system-libvpx. r=glandium
authorRalph Giles <giles@mozilla.com>
Tue, 22 Mar 2016 13:14:18 -0700
changeset 290770 ca78a5af2576347a318789f34060e0abfd5c9640
parent 290769 ff80f543f561301942a8e510470b01f5c9851ad2
child 290771 637e6dce9a3f1210163cfa513292146a7367acd8
push id19656
push usergwagner@mozilla.com
push dateMon, 04 Apr 2016 13:43:23 +0000
treeherderb2g-inbound@e99061fde28a [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersglandium
bugs1257870, 1237023, 1248335
milestone48.0a1
Bug 1257870 - Require 1.5.0 --with-system-libvpx. r=glandium WebRTC code requires VP9E_SET_NOISE_SENSITIVITY from vpx/vp8cx.h which was added in 1.4. We could feature test, but gating on the minimum version seems better given the m4 code is to be replaced by python. We also depend on VPX_MAX_LAYERS wich is part of the 1.5.0 release. This dependency was added with an SVC support patch in May 2015, bug 1237023. Optional --enable-spatial-svc is handled by the work-around in bug 1248335. MozReview-Commit-ID: 79kg9JSFtJM
old-configure.in
--- a/old-configure.in
+++ b/old-configure.in
@@ -4155,17 +4155,17 @@ fi
 
 _SAVE_CFLAGS=$CFLAGS
 _SAVE_LIBS=$LIBS
 if test -n "$MOZ_SYSTEM_LIBVPX"; then
     dnl ============================
     dnl === libvpx Version check ===
     dnl ============================
     dnl Check to see if we have a system libvpx package.
-    PKG_CHECK_MODULES(MOZ_LIBVPX, vpx >= 1.3.0)
+    PKG_CHECK_MODULES(MOZ_LIBVPX, vpx >= 1.5.0)
 
     CFLAGS="$CFLAGS $MOZ_LIBVPX_CFLAGS"
     LIBS="$LIBS $MOZ_LIBVPX_LIBS"
 
     MOZ_CHECK_HEADER([vpx/vpx_decoder.h], [],
      [AC_MSG_ERROR([Couldn't find vpx/vpx_decoder.h which is required for build with system libvpx. Use --without-system-libvpx to build with in-tree libvpx.])])
 
     AC_CHECK_LIB(vpx, vpx_codec_dec_init_ver, [],