Bug 1595218 - Update bootstrap to upgrade to stable rust. r=froydnj
☠☠ backed out by 62a4bef34ce7 ☠ ☠
authorChris Manchester <cmanchester@mozilla.com>
Wed, 04 Dec 2019 23:37:14 +0000
changeset 505569 f2f230a3028d0ac0d951412ea00639cd3508d159
parent 505568 93ec75efbf4117c8a4a6817c0627064d0a3ad31d
child 505570 499b0c27da4fb10f06b17b0b6ad433ed9563412b
push id102348
push usercmanchester@mozilla.com
push dateWed, 04 Dec 2019 23:40:05 +0000
treeherderautoland@499b0c27da4f [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersfroydnj
bugs1595218
milestone73.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1595218 - Update bootstrap to upgrade to stable rust. r=froydnj Differential Revision: https://phabricator.services.mozilla.com/D53900
python/mozboot/mozboot/base.py
--- a/python/mozboot/mozboot/base.py
+++ b/python/mozboot/mozboot/base.py
@@ -153,17 +153,17 @@ ac_add_options --enable-artifact-builds
 
 # Upgrade Mercurial older than this.
 MODERN_MERCURIAL_VERSION = LooseVersion('4.8')
 
 # Upgrade Python older than this.
 MODERN_PYTHON_VERSION = LooseVersion('2.7.3')
 
 # Upgrade rust older than this.
-MODERN_RUST_VERSION = LooseVersion('1.37.0')
+MODERN_RUST_VERSION = LooseVersion('1.39.0')
 
 # Upgrade nasm older than this.
 MODERN_NASM_VERSION = LooseVersion('2.14')
 
 
 class BaseBootstrapper(object):
     """Base class for system bootstrappers."""