Bug 1346014: Update the minimum required version of node to 6.9.1. r=jaws
authorDave Townsend <dtownsend@oxymoronical.com>
Thu, 09 Mar 2017 13:57:20 -0800
changeset 346864 e586e5f9e9a4f0b1febd9433f20754b19a5fc85b
parent 346863 32c79b4aeaaa51260e3b979c7e77f9b193170963
child 346865 cf2b0421dd5795d39c6924f5d761a6369a8a60ad
push id38624
push userdtownsend@mozilla.com
push dateFri, 10 Mar 2017 00:46:13 +0000
treeherderautoland@e586e5f9e9a4 [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersjaws
bugs1346014
milestone55.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1346014: Update the minimum required version of node to 6.9.1. r=jaws MozReview-Commit-ID: Ex0HiKWHfwK
tools/lint/eslint.lint
--- a/tools/lint/eslint.lint
+++ b/tools/lint/eslint.lint
@@ -30,17 +30,17 @@ environment variable, and then at your l
 eslint and needed plugins with:
 
 mach eslint --setup
 
 and try again.
 """.strip()
 
 NODE_NOT_FOUND_MESSAGE = """
-nodejs v4.2.3 is either not installed or is installed to a non-standard path.
+nodejs v6.9.1 is either not installed or is installed to a non-standard path.
 Please install nodejs from https://nodejs.org and try again.
 
 Valid installation paths:
 """.strip()
 
 NPM_NOT_FOUND_MESSAGE = """
 Node Package Manager (npm) is either not installed or installed to a
 non-standard path. Please install npm from https://nodejs.org (it comes as an
@@ -259,18 +259,18 @@ def get_eslint_module_path():
 
 def lint(paths, binary=None, fix=None, setup=None, **lintargs):
     """Run eslint."""
     global project_root
     project_root = lintargs['root']
 
     module_path = get_eslint_module_path()
 
-    # eslint requires at least node 4.2.3
-    node_path = get_node_or_npm_path("node", LooseVersion("4.2.3"))
+    # eslint requires at least node 6.9.1
+    node_path = get_node_or_npm_path("node", LooseVersion("6.9.1"))
     if not node_path:
         return 1
 
     if setup:
         return eslint_setup()
 
     npm_path = get_node_or_npm_path("npm")
     if not npm_path: