Bug 1428049 - [mozlog] Add mozterm as a mozlog dependency and version bump to 3.7, r=igoldan
authorAndrew Halberstadt <ahalberstadt@mozilla.com>
Thu, 04 Jan 2018 10:00:11 -0500
changeset 397789 6310cc3692ff05de803f317639f3b62af272b4d3
parent 397788 c2de67592fbdb1bf09eb122af18aa61b2e3203d2
child 397790 862df5b1a0c918377a22540460538d52f9cda2e1
push id57542
push userahalberstadt@mozilla.com
push dateThu, 04 Jan 2018 18:49:14 +0000
treeherderautoland@6310cc3692ff [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersigoldan
bugs1428049
milestone59.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1428049 - [mozlog] Add mozterm as a mozlog dependency and version bump to 3.7, r=igoldan MozReview-Commit-ID: 8HfH3Jay3KR
testing/mozbase/mozlog/setup.py
--- a/testing/mozbase/mozlog/setup.py
+++ b/testing/mozbase/mozlog/setup.py
@@ -2,30 +2,35 @@
 # License, v. 2.0. If a copy of the MPL was not distributed with this file,
 # You can obtain one at http://mozilla.org/MPL/2.0/.
 
 from __future__ import absolute_import
 
 from setuptools import setup, find_packages
 
 PACKAGE_NAME = 'mozlog'
-PACKAGE_VERSION = '3.6'
+PACKAGE_VERSION = '3.7'
+DEPS = [
+    'blessings>=1.3',
+    'mozterm',
+    'six >= 1.10.0',
+]
+
 
 setup(name=PACKAGE_NAME,
       version=PACKAGE_VERSION,
       description="Robust log handling specialized for logging in the Mozilla universe",
       long_description="see https://firefox-source-docs.mozilla.org/mozbase/index.html",
       author='Mozilla Automation and Testing Team',
       author_email='tools@lists.mozilla.org',
       url='https://wiki.mozilla.org/Auto-tools/Projects/Mozbase',
       license='MPL 1.1/GPL 2.0/LGPL 2.1',
       packages=find_packages(),
       zip_safe=False,
-      install_requires=['blessings >= 1.3',
-                        'six >= 1.10.0'],
+      install_requires=DEPS,
       tests_require=['mozfile'],
       platforms=['Any'],
       classifiers=['Development Status :: 4 - Beta',
                    'Environment :: Console',
                    'Intended Audience :: Developers',
                    'License :: OSI Approved :: Mozilla Public License 1.1 (MPL 1.1)',
                    'Operating System :: OS Independent',
                    'Programming Language :: Python :: 2.7',