testing/config/marionette_source_requirements.txt
author Raphael Pierzina <rpierzina@mozilla.com>
Fri, 05 Oct 2018 19:16:47 +0000
changeset 439965 b2a9499e2c3e3673ea1fae85d5e7f19481f11ca4
child 462881 975644295f21a5bd55d551abd09109a2b7d771eb
permissions -rw-r--r--
Bug 1488468 - Update requirements files for telemetry tests; r=davehunt Depends on D7905 Differential Revision: https://phabricator.services.mozilla.com/D7906

# These dependencies are required for running marionette based tests from a source checkout

-r mozbase_source_requirements.txt

../web-platform/tests/tools/wptserve
../web-platform/tests/tools/third_party/certifi
../web-platform/tests/tools/third_party/enum
../web-platform/tests/tools/third_party/h2
../web-platform/tests/tools/third_party/hyperframe
../web-platform/tests/tools/third_party/hpack

../marionette/client
../marionette/harness
../marionette/harness/marionette_harness/runner/mixins/browsermob-proxy-py

# Allows to use the Puppeteer page object model for Firefox
../marionette/puppeteer/firefox/