Bug 586590 - Configuration of incubator embedding/gtk/x11 with xulrunner 2 is broken. r=mark.finkle
authorAnton Rogaynis <wildriding@gmail.com>
Tue, 17 Aug 2010 10:31:22 -0700
changeset 120 ea7e8d737c55fb58814215a96435438ab559646d
parent 119 4d6bf1b0b33d757ca5659dc44f98b3d720a9d36f
child 121 e48382dbac686aac7d86327e32cf8108a822e964
push id38
push userromaxa@gmail.com
push dateWed, 18 Aug 2010 17:43:40 +0000
reviewersmark.finkle
bugs586590
Bug 586590 - Configuration of incubator embedding/gtk/x11 with xulrunner 2 is broken. r=mark.finkle
gtk/x11/Makefile.am
gtk/x11/configure.ac
--- a/gtk/x11/Makefile.am
+++ b/gtk/x11/Makefile.am
@@ -61,19 +61,19 @@ include_HEADERS = \
 	$(NULL)
 
 noinst_HEADERS = \
 	$(srcdir)/../common/moz-web-view-marshal.h \
 	$(NULL)
 
 MOZ_CFLAGS = -DMOZ_DLL_SUFFIX="\".so\""
 
-CFLAGS += $(MOZ_CFLAGS) $(GTK_CFLAGS) $(LIBXUL_EMBEDDING_UNSTABLE_CFLAGS) -fno-rtti
+CFLAGS += $(MOZ_CFLAGS) $(GTK_CFLAGS) $(LIBXUL_EMBEDDING_CFLAGS) -fno-rtti
 CPPFLAGS += $(CFLAGS)
-LDFLAGS += $(GTK_LIBS) $(LIBXUL_EMBEDDING_UNSTABLE_LIBS)
+LDFLAGS += $(GTK_LIBS) $(LIBXUL_EMBEDDING_LIBS)
 
 pkgconfigdir = $(prefix)/lib/pkgconfig
 
 pkgconfig_DATA = $(top_srcdir)/libmozwebview.pc
 
 MARSHAL_FILE = ../common/moz-web-view-marshal
 MARSHAL_PREFIX = g_cclosure_user_marshal
 
--- a/gtk/x11/configure.ac
+++ b/gtk/x11/configure.ac
@@ -53,26 +53,26 @@ AC_PROG_RANLIB
 AC_CHECK_TOOL(AR, ar)
 AC_HEADER_STDC
 AM_PROG_LIBTOOL
 
 PKG_CHECK_MODULES(GTK, [gtk+-2.0 >= 2.0.0], [], [AC_MSG_ERROR([gtk+-2.0 is required])])
 AC_SUBST(GTK_CFLAGS)
 AC_SUBST(GTK_LIBS)
 
-PKG_CHECK_MODULES(LIBXUL_EMBEDDING_UNSTABLE, [libxul-embedding-unstable], [], [AC_MSG_ERROR([libxul-embedding-unstable is required])])
-AC_SUBST(LIBXUL_EMBEDDING_UNSTABLE_CFLAGS)
-AC_SUBST(LIBXUL_EMBEDDING_UNSTABLE_LIBS)
+PKG_CHECK_MODULES(LIBXUL_EMBEDDING, [libxul-embedding], [], [AC_MSG_ERROR([libxul-embedding is required])])
+AC_SUBST(LIBXUL_EMBEDDING_CFLAGS)
+AC_SUBST(LIBXUL_EMBEDDING_LIBS)
 
 dnl marshal generator
 GLIB_GENMARSHAL="`$PKG_CONFIG --variable=glib_genmarshal glib-2.0`"
 AC_SUBST(GLIB_GENMARSHAL)
 
 LIBMOZWEBVIEW_REQUIRES="gtk+-2.0 libxul-embedding-unstable"
-PACKAGE_CFLAGS="$MOZILLA_JS_CFLAGS $LIBXUL_EMBEDDING_UNSTABLE_CFLAGS $GTK_CFLAGS"
+PACKAGE_CFLAGS="$MOZILLA_JS_CFLAGS $LIBXUL_EMBEDDING_CFLAGS $GTK_CFLAGS"
 
 AC_SUBST(LIBMOZWEBVIEW_REQUIRES)
 AC_SUBST(PACKAGE_CFLAGS)
 
 AC_OUTPUT([
 Makefile
 libmozwebview.pc
 ])