xpi/resources/install.rdf
author Justin Wood <Callek@gmail.com>
Fri, 31 Aug 2012 01:05:32 -0400
branchSEA2_13_RELBRANCH
changeset 1621 79e62e95c582a4920becabef57a722b2e9d032c3
parent 1598 e25c0b12b768551311a72d136b0fa9c66ba0cbc4
child 1659 1e6fa0b11c8f6c302fc3d805456d7a312151b470
permissions -rw-r--r--
No Bug - Update Chatzilla Compat Versions. rs=Silver

<?xml version="1.0"?>
<!-- This Source Code Form is subject to the terms of the Mozilla Public
   - License, v. 2.0. If a copy of the MPL was not distributed with this
   - file, You can obtain one at http://mozilla.org/MPL/2.0/. -->

#filter substitution

<RDF xmlns="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
     xmlns:em="http://www.mozilla.org/2004/em-rdf#">
  <Description about="urn:mozilla:install-manifest">
    <!-- core data -->
    <em:id>{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}</em:id>
    <em:version>@CHATZILLA_VERSION@</em:version>

    <!-- BEGIN COPY BETWEEN /xpi/resources/install.rdf AND /locales/generic/install.rdf -->
    <!-- ChatZilla supports Gecko 1.9.1 and higher.
         All applications listed below are the subset of supported versions
         which also use an appropriate version of Gecko. -->
    <!-- For maxVersion of applications that follow the rapid cycle pattern,
         use '(x)a1' (*-central) on default,
         and '(x-1).*' (*-aurora/beta/release) for branches. -->

    <!-- Firefox
         3.5 is Gecko 1.9.1
         3.6 is Gecko 1.9.2
         4.0 is Gecko 2.0
         5.0 is Gecko 5.0
         x.0 is Gecko x.0, where x is greater than 5 -->
    <em:targetApplication>
      <Description>
        <em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
        <em:minVersion>3.5</em:minVersion>
        <em:maxVersion>18.0a1</em:maxVersion>
      </Description>
    </em:targetApplication>

    <!-- SeaMonkey
         2.0 is Gecko 1.9.1
         2.1 is Gecko 2.0
         2.2 is Gecko 5.0
         2.x is Gecko (x+3).0, where x is greater than 2 -->
    <em:targetApplication>
      <Description>
        <em:id>{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}</em:id>
        <em:minVersion>2.0</em:minVersion>
        <em:maxVersion>2.15a1</em:maxVersion>
      </Description>
    </em:targetApplication>

    <!-- Songbird
         1.9 is Gecko 1.9.2
         1.10 is Gecko 1.9.2 -->
    <em:targetApplication>
      <Description>
        <em:id>songbird@songbirdnest.com</em:id>
        <em:minVersion>1.9</em:minVersion>
        <em:maxVersion>1.10.*</em:maxVersion>
      </Description>
    </em:targetApplication>
    <!-- END COPY BETWEEN /xpi/resources/install.rdf AND /locales/generic/install.rdf -->

    <!-- front-end metadata -->
    <em:name>ChatZilla</em:name>
    <em:description>A clean, easy to use and highly extensible Internet Relay Chat (IRC) client.</em:description>
    <em:creator>The ChatZilla Team</em:creator>
    <em:contributor>Lim Chee Aun (graphics)</em:contributor>
    <em:contributor>Robert Ginda</em:contributor>
    <em:contributor>Gijs Kruitbosch</em:contributor>
    <em:contributor>James Ross</em:contributor>
    <em:contributor>Samuel Sieb</em:contributor>
    <em:iconURL>chrome://chatzilla/skin/images/logo.png</em:iconURL>
    <em:homepageURL>http://chatzilla.hacksrus.com/</em:homepageURL>
    <em:aboutURL>chrome://chatzilla/content/about/about.xul</em:aboutURL>
    <em:optionsURL>chrome://chatzilla/content/config.xul</em:optionsURL>

    <!-- package files -->
    <em:file>
      <Description about="urn:mozilla:extension:file:chatzilla.jar">
        <em:package>content/chatzilla/</em:package>
        <em:package>content/chatzilla/ff/</em:package>
        <em:locale>locale/en-US/chatzilla/</em:locale>
        <em:skin>skin/modern/chatzilla/</em:skin>
      </Description>
    </em:file>

    <!-- Force unpack the xpi, otherwise window icons do not work
         on Gecko 2.0 and higher. -->
    <em:unpack>true</em:unpack>
  </Description>
</RDF>