Bug 1385792 - Release notes and website update for SeaMonkey 2.49.1. r=IanN
authorFrank-Rainer Grahl <frgrahl@gmx.net>
Sat, 04 Nov 2017 18:10:44 +0100
changeset 1282 249a3865caf6
parent 1281 c9ba679786bf
child 1283 4cf3c77c5480
push id62
push userfrgrahl@gmx.net
push dateSat, 04 Nov 2017 17:11:04 +0000
reviewersIanN
bugs1385792
Bug 1385792 - Release notes and website update for SeaMonkey 2.49.1. r=IanN
lib/config.tmpl
lib/sitemap.xml
src/doc/system-requirements.en.html
src/news.en.xml
src/releases/2.48.en.html
src/releases/2.49.1.en.html
src/releases/legacy.en.html
src/releases/seamonkey2.49.1/index.en.html
src/releases/seamonkey2.49.1/relnote.var
--- a/lib/config.tmpl
+++ b/lib/config.tmpl
@@ -7,18 +7,18 @@
 [% toplink = "${template.name}"|replace('[^\/]+/','../')|replace('[^\/]*$','') %]
 [% IF toplink == '' %]
   [% toplink = './' %]
 [% END %]
 [% IF template.name == '404.en.html' %]
   [% toplink = '/' %]
 [% END %]
 
-[% releaseversion = '2.48' %]
-[% releaserelnoteversion = '2.48' %]
+[% releaseversion = '2.49.1' %]
+[% releaserelnoteversion = '2.49.1' %]
 [% releasename = "SeaMonkey $releaseversion" %]
 [% relnotes = "${toplink}releases/seamonkey$releaserelnoteversion/" %]
 [% download_win = "https://download.mozilla.org/?product=seamonkey-$releaseversion&amp;os=win&amp;lang=en-US" %]
 [% download_linux = "https://download.mozilla.org/?product=seamonkey-$releaseversion&amp;os=linux&amp;lang=en-US" %]
 [% download_mac = "https://download.mozilla.org/?product=seamonkey-$releaseversion&amp;os=osx&amp;lang=en-US" %]
 [% download_more = "${toplink}releases/#$releaseversion" %]
 [%# releases.mozilla.org disabled, see bug 871120 %]
 [%# download_allfiles = "http://releases.mozilla.org/pub/seamonkey/releases/$releaseversion/" %]
@@ -27,11 +27,11 @@
 [% download_linux_mb = 45 %]
 [% download_mac_mb = 70 %]
 
 [% betabaseversion = '2.48' %]
 [% betabetaversion = '1' %]
 [% betaversion = "${betabaseversion}b${betabetaversion}" %]
 [% betaname = "SeaMonkey ${betabaseversion} Beta ${betabetaversion}" %]
 
-[% develbaseversion = '2.53' %]
+[% develbaseversion = '2.55' %]
 [% develversion = "${develbaseversion}a1" %]
 [% develdownloadbase = 'https://archive.mozilla.org/pub/seamonkey/nightly/latest-comm-central-trunk' %]
--- a/lib/sitemap.xml
+++ b/lib/sitemap.xml
@@ -8,17 +8,20 @@ http://www.damowmow.com/portal/ (use the
 
 <site title="SeaMonkey Project" url="http://seamonkey-project.org">
 
   <page url="." title="Home" id="home" />
 
   <page url="news" title="News" id="news" />
 
   <page url="releases/" title="Download and Releases" id="releases">
-    <page url="releases/2.48" title="2.48" id="2.48" hide="false">
+    <page url="releases/2.49.1" title="2.49.1" id="2.49.1" hide="false">
+      <page url="releases/seamonkey2.49.1/" title="Release Notes" id="seamonkey2.49.1"/>
+    </page>
+    <page url="releases/2.48" title="2.48" id="2.48" hide="true">
       <page url="releases/seamonkey2.48/" title="Release Notes" id="seamonkey2.48"/>
     </page>
     <page url="releases/2.48b1" title="2.48 Beta 1" id="2.48b1" hide="true" />
     <page url="releases/2.46" title="2.46" id="2.46" hide="true">
       <page url="releases/seamonkey2.46/" title="Release Notes" id="seamonkey2.46"/>
     </page>
     <page url="releases/2.40" title="2.40" id="2.40" hide="true">
       <page url="releases/seamonkey2.40/" title="Release Notes" id="seamonkey2.40"/>
--- a/src/doc/system-requirements.en.html
+++ b/src/doc/system-requirements.en.html
@@ -52,17 +52,17 @@
 <h2 id="linux">Linux</h2>
 <div class="section">
   <h3>Software Requirements</h3>
   Please note that Linux distributors may provide packages for your
   distribution which have different requirements.
   <ul>
     <li>The following library versions (or compatible) are required:
       <ul>
-        <li>GTK+ 2.18 or higher</li>
+        <li>GTK+ 3.4 or higher</li>
         <li>GLib 2.22 or higher</li>
         <li>Pango 1.14 or higher</li>
         <li>X.Org 1.0 or higher (Recommended: 1.7 or higher)</li>
         <li>libstdc++ 4.6.1 or higher</li>
       </ul>
     </li>
     <li>Recommended for optimal functionality:
       <ul>
--- a/src/news.en.xml
+++ b/src/news.en.xml
@@ -2,27 +2,61 @@
 
 <!--
 non-ASCII characters must be DOUBLE-escaped;
 you can use Hixie's converter to get the entity codes
 http://www.damowmow.com/portal/ (use the "Indentify" field)
 -->
 
 <newsfeed title="SeaMonkey News" url="http://seamonkey-project.org/news">
+  <entry id="2017-11-04" showfront="true">
+    <headline>SeaMonkey 2.49.1 released</headline>
+    <content type="html" xml:lang="en">
+<![CDATA[<p>
+The SeaMonkey project is proud to present SeaMonkey 2.49.1: The new major
+release of the all-in-one Internet suite is
+<a href="http://www.seamonkey-project.org/releases/">available for download
+now</a>! Building on the same Mozilla platform as Firefox 52.4 ESR, it
+delivers those same developments in web technologies such as HTML5, hardware
+acceleration and improved JavaScript speed.
+</p>
+<p>
+SeaMonkey 2.49.1 is available in 20 languages, for Windows, Mac OS X and Linux.
+</p>
+<p>
+<font size="+2" color="#ff0000"><b>Automatic upgrades from versions prior to
+2.48 are, for most configurations, disabled for this release. If you need to
+upgrade from an earlier version, please download the full installer from the
+downloads section and install SeaMonkey 2.49.1 manually over the previous
+version.</b></font><br>
+</p>
+<p>
+For a more complete list of major changes in SeaMonkey 2.49.1, see the
+<a href=http://www.seamonkey-project.org/releases/seamonkey2.49.1/#new>What's
+New in SeaMonkey 2.49.1</a> section of the
+<a href="http://www.seamonkey-project.org/releases/seamonkey2.49.1/">Release
+Notes</a>, which also contain a list of known issues and answers to frequently
+asked questions. For a more general overview of the SeaMonkey project (and <a
+href="http://www.seamonkey-project.org/doc/screenshots">screen shots</a>!),
+visit <a href="http://www.seamonkey-project.org/">www.seamonkey-project.org</a>.
+</p>]]>
+    </content>
+  </entry>
+
   <entry id="2017-08-13" showfront="true">
     <headline>Download problems with NoScript active</headline>
     <content type="html" xml:lang="en">
 <![CDATA[<p>
 If you are using NoScript you might encounter a certificate error when trying
 to download SeaMonkey from this site. NoScript tries to force an https
 connection for an http only site. It is not a NoScript problem but how the
 Mozilla server, from which downloads are delivered, is configured.
 </p>
 <p>
-In this case please add download.cdn.mozilla.net to the NoScript 
+In this case please add download.cdn.mozilla.net to the NoScript
 "Never force secure (HTTPS) connections" options or turn off NoScript for
 this download only. The settings are located in the NoScript options under
 "Advanced->HTTPS".
 </p>]]>
     </content>
   </entry>
 
   <entry id="2017-07-31" showfront="true">
@@ -35,19 +69,19 @@ for download now</a>!
 Building on the same Mozilla platform as Firefox 51, it
 delivers those same developments in web technologies such as HTML5, hardware
 acceleration and improved JavaScript speed.
 </p>
 <p>
 SeaMonkey 2.48 is available in 19 languages, for Windows, Mac OS X and Linux.
 </p>
 <p>
-<font size="+2" color="#ff0000"><b>Automatic upgrades from previous versions are, for most configurations,
+Automatic upgrades from previous versions are, for most configurations,
 disabled for this release. If you need to upgrade from an earlier version, please download the full installer
-from the downloads section and install SeaMonkey 2.48 manually over the previous version.</b></font><br>
+from the downloads section and install SeaMonkey 2.48 manually over the previous version.
 </p>
 <p>
 For a more complete list of major changes in SeaMonkey 2.48, see the
 <a href=http://www.seamonkey-project.org/releases/seamonkey2.48/#new>What's New in SeaMonkey 2.48</a>
 section of the <a href="http://www.seamonkey-project.org/releases/seamonkey2.48/">Release
 Notes</a>, which also contain a list of known issues and answers to frequently
 asked questions. For a more general overview of the SeaMonkey project (and <a
 href="http://www.seamonkey-project.org/doc/screenshots">screen shots</a>!),
--- a/src/releases/2.48.en.html
+++ b/src/releases/2.48.en.html
@@ -1,13 +1,13 @@
 [%- PROCESS release.tmpl -%]
 [%- smversion = '2.48' -%]
 [%- prettyversion = '2.48' -%]
 [%- relnoteversion = '2.48' -%]
-[%- mirrorred = true -%]
+[%- mirrorred = false -%]
 [%- uselongversion = false -%]
 [%- releasedate = "July 31, 2017" -%]
 [%- srcsize = "168" -%]
 <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
 <html lang="en">
 <head>
 
 <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
@@ -19,26 +19,25 @@
 <link rel="up" href="./" title="SeaMonkey Releases">
 
 <title>SeaMonkey [% prettyversion %]</title>
 </head>
 <body>
 <h1><a name="[% smversion %]">SeaMonkey [% prettyversion %]</a></h1>
 <p class="release-date">Released [% releasedate %]</p>
 
-<!-- <div class="important">
+<div class="important">
   <strong class="very-strong shout">Warning!</strong> The SeaMonkey version
   available for download from this page is outdated and may suffer from
   <a href="http://www.mozilla.org/security/known-vulnerabilities/#SeaMonkey">known
   security vulnerabilities</a>. This page is only available for historic
   reference.
   <br>We strongly advise you to download the <a href="./">current release</a>
   instead.
 </div>
--->
 
 <ul class="toc">
   <li><a href="#official">Official Builds</a></li>
   <li><a href="#source">Source Code</a></li>
   <li><a href="#langpacks">Language Packs</a></li>
   <li><a href="#contrib">Contributed builds (other platforms)</a></li>
 </ul>
 
copy from src/releases/2.48.en.html
copy to src/releases/2.49.1.en.html
--- a/src/releases/2.48.en.html
+++ b/src/releases/2.49.1.en.html
@@ -1,15 +1,15 @@
 [%- PROCESS release.tmpl -%]
-[%- smversion = '2.48' -%]
-[%- prettyversion = '2.48' -%]
-[%- relnoteversion = '2.48' -%]
+[%- smversion = '2.49.1' -%]
+[%- prettyversion = '2.49.1' -%]
+[%- relnoteversion = '2.49.1' -%]
 [%- mirrorred = true -%]
 [%- uselongversion = false -%]
-[%- releasedate = "July 31, 2017" -%]
+[%- releasedate = "November 4, 2017" -%]
 [%- srcsize = "168" -%]
 <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
 <html lang="en">
 <head>
 
 <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
 <meta http-equiv="Content-Language" content="en">
 <meta http-equiv="Content-Style-Type" content="text/css">
@@ -52,20 +52,22 @@
   <li>If you are using NoScript you might encounter a certificate error when trying
   to download SeaMonkey from this site. NoScript tries to force an https
   connection for an http only site. It is not a NoScript problem but how the
   Mozilla server, from which downloads are delivered, is configured.<br>
   In this case please add download.cdn.mozilla.net to the NoScript
   "Never force secure (HTTPS) connections" options or turn off NoScript for this download
   only. The settings are located in the NoScript options under "Advanced->HTTPS".
   </li>
-  <li><font size="+2" color="#ff0000"><b>Automatic upgrades from previous versions are,
-  for most configurations, disabled for this release. If you need to upgrade from an earlier
-  version, please download the full installer from the downloads section and install SeaMonkey
-  2.48 manually over the previous version.</b></font>
+  <li><font size="+2" color="#ff0000"><b>Automatic upgrades from versions prior
+  to 2.48 are, for most configurations, disabled for this release. If you need
+  to upgrade from an earlier version, please download the full installer from
+  the downloads section and install SeaMonkey 2.49.1 manually over the previous
+  version.</b></font><br>
+
   </li>
 </ul>
 </div>
 
 <h2 id="official">Official builds</h2>
 <div class="section">
 <p class="note"><a href="[% INCLUDE download_file path='MD5SUMS' %]">MD5
   sums</a> and <a href="[% INCLUDE download_file path='SHA1SUMS' %]">SHA1
@@ -182,65 +184,73 @@
     <tr id="lt" class="even">
       <td>Lithuanian</td>
       <td lang="lt">lietuvių kalba</td>
       <td class="curVersion">[% smversion %]</td>
       <td><a href="[% INCLUDE download_build platform='win' locale='lt' %]" class="download-win">Download</a></td>
       <td><a href="[% INCLUDE download_build platform='osx' locale='lt' %]" class="download-mac">Download</a></td>
       <td><a href="[% INCLUDE download_build platform='linux' locale='lt' %]" class="download-linux">Download</a></td>
     </tr>
-    <tr id="pl" class="odd">
+    <tr id="nb-NO" class="odd">
+      <td>Norwegian (Bokmål)</td>
+      <td lang="nb-NO">Norsk bokmål</td>
+      <td class="curVersion">[% smversion %]</td>
+      <td><a href="[% INCLUDE download_build platform='win' locale='nb-NO' %]" class="download-win">Download</a></td>
+      <td><a href="[% INCLUDE download_build platform='osx' locale='nb-NO' %]" class="download-mac">Download</a></td>
+      <td><a href="[% INCLUDE download_build platform='linux' locale='nb-NO' %]" class="download-linux">Download</a></td>
+    </tr>
+    <tr id="pl" class="even">
       <td>Polish</td>
       <td lang="pl">Polski</td>
       <td class="curVersion">[% smversion %]</td>
       <td><a href="[% INCLUDE download_build platform='win' locale='pl' %]" class="download-win">Download</a></td>
       <td><a href="[% INCLUDE download_build platform='osx' locale='pl' %]" class="download-mac">Download</a></td>
       <td><a href="[% INCLUDE download_build platform='linux' locale='pl' %]" class="download-linux">Download</a></td>
     </tr>
-    <tr id="pt-PT" class="even">
+    <tr id="pt-PT" class="odd">
       <td>Portuguese (Portugal)</td>
       <td lang="pt-PT">Português (Europeu)</td>
       <td class="curVersion">[% smversion %]</td>
       <td><a href="[% INCLUDE download_build platform='win' locale='pt-PT' %]" class="download-win">Download</a></td>
       <td><a href="[% INCLUDE download_build platform='osx' locale='pt-PT' %]" class="download-mac">Download</a></td>
       <td><a href="[% INCLUDE download_build platform='linux' locale='pt-PT' %]" class="download-linux">Download</a></td>
     </tr>
-    <tr id="ru" class="odd">
+    <tr id="ru" class="even">
       <td>Russian</td>
       <td lang="ru">Русский</td>
       <td class="curVersion">[% smversion %]</td>
       <td><a href="[% INCLUDE download_build platform='win' locale='ru' %]" class="download-win">Download</a></td>
       <td><a href="[% INCLUDE download_build platform='osx' locale='ru' %]" class="download-mac">Download</a></td>
       <td><a href="[% INCLUDE download_build platform='linux' locale='ru' %]" class="download-linux">Download</a></td>
     </tr>
-    <tr id="sk" class="even">
+    <tr id="sk" class="odd">
       <td>Slovak</td>
       <td lang="sk">slovenčina</td>
       <td class="curVersion">[% smversion %]</td>
       <td><a href="[% INCLUDE download_build platform='win' locale='sk' %]" class="download-win">Download</a></td>
       <td><a href="[% INCLUDE download_build platform='osx' locale='sk' %]" class="download-mac">Download</a></td>
       <td><a href="[% INCLUDE download_build platform='linux' locale='sk' %]" class="download-linux">Download</a></td>
     </tr>
-    <tr id="es-AR" class="odd">
+    <tr id="es-AR" class="even">
       <td>Spanish (Argentina)</td>
       <td lang="es-AR">Español (de Argentina)</td>
       <td class="curVersion">[% smversion %]</td>
       <td><a href="[% INCLUDE download_build platform='win' locale='es-AR' %]" class="download-win">Download</a></td>
       <td><a href="[% INCLUDE download_build platform='osx' locale='es-AR' %]" class="download-mac">Download</a></td>
       <td><a href="[% INCLUDE download_build platform='linux' locale='es-AR' %]" class="download-linux">Download</a></td>
     </tr>
-    <tr id="es-ES" class="even">
+    <tr id="es-ES" class="odd">
       <td>Spanish (Spain)</td>
       <td lang="es-ES">Español (de España)</td>
       <td class="curVersion">[% smversion %]</td>
       <td><a href="[% INCLUDE download_build platform='win' locale='es-ES' %]" class="download-win">Download</a></td>
       <td><a href="[% INCLUDE download_build platform='osx' locale='es-ES' %]" class="download-mac">Download</a></td>
       <td><a href="[% INCLUDE download_build platform='linux' locale='es-ES' %]" class="download-linux">Download</a></td>
     </tr>
-    <tr id="sv-SE" class="odd">
+    <tr id="sv-SE" class="even">
       <td>Swedish</td>
       <td lang="sv-SE">Svenska</td>
       <td class="curVersion">[% smversion %]</td>
       <td><a href="[% INCLUDE download_build platform='win' locale='sv-SE' %]" class="download-win">Download</a></td>
       <td><a href="[% INCLUDE download_build platform='osx' locale='sv-SE' %]" class="download-mac">Download</a></td>
       <td><a href="[% INCLUDE download_build platform='linux' locale='sv-SE' %]" class="download-linux">Download</a></td>
     </tr>
   </tbody>
@@ -269,23 +279,25 @@
 <h2 id="langpacks">Language Packs</h2>
 <div class="section">
   <p>See the <a href="langpack-notes/2.0">activation notes</a> for how to install those packages.</p>
   <p>
     <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.zh-CN.langpack.xpi" %]">Chinese (Simplified)</a>,
     <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.zh-TW.langpack.xpi" %]">Chinese (Traditional)</a>,
     <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.cs.langpack.xpi" %]">Czech</a>,
     <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.nl.langpack.xpi" %]">Dutch</a>,
+    <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.en-US.langpack.xpi" %]">English (US)</a>,
     <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.en-GB.langpack.xpi" %]">English (British)</a>,
     <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.fr.langpack.xpi" %]">French</a>,
     <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.de.langpack.xpi" %]">German</a>,
     <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.hu.langpack.xpi" %]">Hungarian</a>,
     <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.it.langpack.xpi" %]">Italian</a>,
     <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.ja.langpack.xpi" %]">Japanese</a>,
     <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.lt.langpack.xpi" %]">Lithuanian</a>,
+    <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.nb-NO.langpack.xpi" %]">Norwegian (Bokmål)</a>,
     <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.pl.langpack.xpi" %]">Polish</a>,
     <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.pt-PT.langpack.xpi" %]">Portuguese (Portugal)</a>,
     <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.ru.langpack.xpi" %]">Russian</a>,
     <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.sk.langpack.xpi" %]">Slovak</a>,
     <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.es-AR.langpack.xpi" %]">Spanish (Argentina)</a>,
     <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.es-ES.langpack.xpi" %]">Spanish (Spain)</a>,
     <a href="[% INCLUDE download_file path="langpack/seamonkey-${smversion}.sv-SE.langpack.xpi" %]">Swedish</a>,
   </p>
--- a/src/releases/legacy.en.html
+++ b/src/releases/legacy.en.html
@@ -21,19 +21,20 @@
     Requirements</a>). We do not support any of the applications and versions
     listed below. If your operating system or computer is no longer supported
     by official SeaMonkey releases, the only way to continue using officially
     supported SeaMonkey versions is to upgrade your operating system and/or
     computer.</p>
 </div>
 
 <ul>
-  <li>SeaMonkey 2.48 is the last version with gtk2 support on Linux.</li>
+
   <li>SeaMonkey 2.49.x will be the last version supporting Windows XP/Server 2003 and Vista/Server 2008.</li>
   <li>SeaMonkey 2.49.x will be the last version with ALSA support on Linux.</li>
+  <li>The last version with gtk2 support on Linux was SeaMonkey 2.48.</li>
   <li>The last version with Mac OS 10.8 support was SeaMonkey 2.40.</li>
   <li>The last version for Windows with support for older CPUs not supporting the SSE2 instruction set was SeaMonkey 2.40.</li>
   <li>The last version with Windows 2000 and Windows XP without SP2 support was SeaMonkey 2.9.</li>
   <li>The last version with Mac OS 10.4 and PPC support was SeaMonkey 2.0.14.</li>
   <li>The last version with Windows 98/Me support was SeaMonkey 1.1.19.</li>
 </ul>
 
 <h2>Third-Party Projects</h2>
copy from src/releases/seamonkey2.48/index.en.html
copy to src/releases/seamonkey2.49.1/index.en.html
--- a/src/releases/seamonkey2.48/index.en.html
+++ b/src/releases/seamonkey2.49.1/index.en.html
@@ -15,43 +15,51 @@
 
 <title>[% rnote.basename %] Release Notes</title>
 </head>
 <body>
 <h1>[% rnote.basename %]</h1>
 
 <div class="key-point">
 <p>
-<font size="+2" color="#ff0000"><b>Automatic upgrades from previous versions are
-not working for this release. Please download the full installer from the downloads section and
-install SeaMonkey 2.48 manually over the previous version.</b></font>
+<font size="+2" color="#ff0000"><b>Automatic upgrades from versions prior to
+2.48 are not working for this release. Please download the full installer from
+the downloads section and install SeaMonkey 2.49.1 manually over the previous
+version.</b></font>
 </p>
 </div>
 
 <div class="key-point">
-<p>The Mozilla backend code SeaMonkey is based on, now usually incorporates breaking changes in every release.
-This is especially true for the Mozilla Gecko add-ons code and the JavaScript interpreter.
-Consequently, some older extensions <em>may</em> no longer function properly.
-If you experience any problems please refer to the troubleshooting section first. Especially try to disable extensions
+<p>The Mozilla backend code SeaMonkey is based on, now usually incorporates
+breaking changes in every release. This is especially true for the Mozilla Gecko
+add-ons code and the JavaScript interpreter. Consequently, some older extensions
+<em>may</em> no longer function properly. If you experience any problems please
+refer to the troubleshooting section first. Especially try to disable extensions
 first and check if this makes a difference.
 <br>
-We advise you to back up your profile before upgrading in case you want to go back to a previous version of SeaMonkey.
+We advise you to back up your profile before upgrading in case you want to go
+back to a previous version of SeaMonkey.
 </p>
 </div>
 
 <div class="key-point">
 <p>
 For [% rnote.basename %], the following extensions are removed and are not
 included in the distribution (due to repack issues).
 <ul>
   <li><a href="https://addons.mozilla.org/en-US/seamonkey/addon/chatzilla/">Chatzilla</a></li>
-  <li><a href="https://l10n.mozilla-community.org/~akalla/unofficial/seamonkey/nightly/latest-comm-release-windows32/inspector-2.0.17.0.xpi">DOM Inspector</a>
-    DOM Inspector 2.0.16.1 available on the Mozilla Add-Ons page is not compatible with SeaMonkey 2.48. Please use version 2.0.17.0 provided by Adrian Kalla.
+  <li><a href="https://addons.mozilla.org/en-US/seamonkey/addon/dom-inspector-6622/">DOM Inspector</a>
+    DOM Inspector 2.0.16.1 available on the Mozilla Add-Ons page is not
+    compatible with SeaMonkey 2.49.1. You need to use version 2.0.17.0 or
+    higher. You can install it from
+    <a href="https://archive.mozilla.org/pub/seamonkey/releases/2.49.1/distributed/inspector@mozilla.org.xpi">DOM Inspector 2.0.17.1</a>.
+    This version is compatible with SeaMonkey 2.1 to 2.53 and Thunderbird
+    4.0 to 56.0.
     </li>
-  <li><a href="https://addons.mozilla.org/en-US/seamonkey/addon/lightning/versions/beta?page=1#version-5.3b2">Lightning</a> </li>
+  <li><a href="https://www.mozilla.org/en-US/projects/calendar/">Lightning 5.4</a> </li>
 </ul>
 </p>
 <p>Unless stated otherwise they can be obtained from <a href="https://addons.mozilla.org/">AMO</a>.</p>
 </div>
 
 <div class="key-point">
 <p>
 These release notes describe system requirements, installation instructions,
@@ -63,37 +71,63 @@ for new information.
 
 <h2 id="new">What's New in [% rnote.basename %]</h2>
 <div class="section">
 <p>
 [% rnote.basename %] contains (among other changes) the following major changes relative to
 <a href="../seamonkey[% rnote.relativeto.version %]/#new">[% rnote.relativeto.name %]</a>:
 </p>
 <p>
-SeaMonkey 2.48 uses the same backend as Firefox and contains the listed
-<a href="https://www.mozilla.org/en-US/security/known-vulnerabilities/firefox/#firefox51.0.3">Firefox 51.0.3 security fixes"</a>.
+SeaMonkey 2.49.1 uses the same backend as Firefox and contains the listed
+<a href="https://www.mozilla.org/en-US/security/known-vulnerabilities/firefox-esr/#firefoxesr52.4">Firefox 52.4 ESR security fixes</a>.
 </p>
+<p>
+SeaMonkey 2.49.1 shares most parts of the mail and news code with Thunderbird. Please read the
+<a href="https://www.thunderbird.net/en-US/thunderbird/52.4.0/releasenotes/">Thunderbird 52.4 ESR release notes</a> for
+specific changes and security fixes in this release.
+</p>
+
 <h3>SeaMonkey-specific changes</h3>
 <ul>
-  <li>The bug which prevented you to set the default search engine in SeaMonkey 2.46 has been fixed.
-    If you see any problems with this please report it in
-    <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1265881">bug 1265881</a>.</li>
-  <li>Troubleshooting Information in "about:support" is displayed in a better readable layout.</li>
-  <li>Language support for be, ca, fi, gl, nb-No, tr and uk has been dropped
-    because the languages are no longer updated for SeaMonkey.</li>
-</ul>
-<h3>Developer Notes</h3>
-<ul>
-  <li>The Error Console is now a part of SeaMonkey. It was replaced by the Developer Tools Web
-    and Browser Console in Firefox which both are also available in SeaMonkey.
-    If you use css to style the console please note that it is now located in
-    "chrome://communicator/content/console/console.xul/".</li>
-  <li>The Help Viewer is now a part of SeaMonkey and has been deleted from Mozilla Gecko.</li>
-  <li>SeaMonkey now uses the HTTP cache v2. For technical details please check
-    <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1241622">bug 1241622</a>.</li>
+  <li>SeaMonkey should no longer crash when you start it or try to use the mail
+    feature on OS X 10.12 or greater.
+    </li>
+  <li>You were not always prompted for authentication in SeaMonkey 2.48 under
+    certain scenarios resulting in login failures. The problem, tracked in
+    <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1347857">bug 1347857</a>,
+    has been fixed.
+    </li>
+  <li>Mail and News: The way images are included in a compose window has
+    changed. Images are now included as data URIs and not as references to
+    parts of other messages or operating system files. This allows better
+    interoperability with office packages such as MS Office or LibreOffice.
+    Images linked from locations on the internet will no longer be downloaded
+    and attached to the message automatically. This can be changed globally by
+    setting the preference mail.compose.attach_http_images.
+    </li>
+  <li>Language support for nb-NO has been re-added.
+    </li>
+  <li>SeaMonkey now uses gtk3 on Linux. If you experience a problem because of
+    this please file a bug and link it to
+    <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1367257">Switch Linux builds to GTK3 with SeaMonkey 2.49</a>.
+    Pleae try another OS theme first. Some of them are buggy and cause problems
+    with SeaMonkey, Thunderbird and Firefox.
+    </li>
+  <li>Quotes are now colored differently in Mails
+    <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1374708">bug 1374708</a>.
+    </li>
+  <li>Under OSX the left panes in Bookmarks Manager, MailNews and Address Book
+    are now styled like finder panes. See
+    <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1095904">bug 1095904</a>.
+    </li>
+  <li>Quotes are now colored differently in Mails up to 5 levels deep depending
+    on your OS. See <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1374708">bug 1374708</a>.
+    This may break custom themes for email composition because a new style
+    sheet named &quot;messageQuotes.css&quot; has been added.
+    </li>
 </ul>
 
 </div>
 
 <h2 id="download">Downloading</h2>
 <div class="section">
 The SeaMonkey project provides official versions of [% rnote.name %] for
 Windows, Linux, and Mac OS X in US English and experimental language packs for
@@ -159,39 +193,28 @@ e.g. happens when you install the Add-on
   a replacement.</p>
 </div>
 
 <h2 id="issues">Known Issues</h2>
 <div class="section">
 This list covers some of the known problems with [% rnote.name %].
 Please read this before reporting any new bugs.
 <ul>
-  <li>There is a known problem with SeaMonkey 2.48 crashing for some users on OS X 10.12 or greater.
-    If you experience a crash when starting SeaMonkey or trying to use mail or news please go back to 2.46
-    for now. To fix the crash we would need to port some changes back from a later release, which is still in
-    internal testing. This might break other things so, instead, we are trying to get the next 2.49.1 release
-    out of the door as fast as we can.
-    </li>
   <li>If you experience a hang and/or get a message box that a script is busy when opening the Data Manager
     try deleting the webappsstore.* files from your profile folder when SeaMonkey is not running.
     These contain data stored by web sites and will be recreated during the next start.
     If you are unsure if the information is needed please back them up before deleting them.
     The problem is tracked in <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1305624">bug 1305624</a>
     but so far no coding error has been found.
     </li>
-  <li>Changes in the Mozilla password prompting code caused an incompatibility and you may no longer be prompted for
-    authentication in certain scenarios. The problem is tracked in
-    <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1347857">bug 1347857</a>.
-    Check the bug for workarounds. The issue will be fixed in the next SeaMonkey release.
-    </li>
   <li>If your are running Windows 7 or lower "Send to > Mail recipient" might not work.
     The problem was originally reported against Thunderbird 52 and is tracked in
     <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1356902">bug 1356902</a>.
     As a workaround install the Microsoft Visual Studio 2015 or 2017 redistributable runtime library.
-    SeaMonkey is compiled for x86 so you only need this version
+    Official SeaMonkey builds are compiled for x86 so you only need this version
     <a href="https://go.microsoft.com/fwlink/?LinkId=746571">VS2017 x86 runtime</a>.
     The runtime can be installed on any Windows version starting with Windows XP SP3.
     If you already have a VS2015 runtime installed you do not need to upgrade it to a later version.
     </li>
 
   <li>The SSL 3.0 encryption protocol is no longer supported due to
     security concerns (<a
     href="https://bugzilla.mozilla.org/show_bug.cgi?id=1106470">bug
@@ -252,32 +275,16 @@ Please read this before reporting any ne
         will experience this even if they haven't turned
         off hardware acceleration in Preferences (Appearance/Content) (<a
         href="https://bugzilla.mozilla.org/show_bug.cgi?id=626096">bug 626096</a>).</li>
     </ul>
   </li>
 </ul>
 </div>
 
-<h2 id="issuesfixedbeta">Fixed issued compared to [% rnote.basename %] Beta 1</h2>
-<div class="section">
-This list covers some of the fixed issues compared to [% rnote.name %] Beta 1.
-<ul>
-  <li>The code has been updated to include the latest Firefox 51 fixes.</li>
-  <li>Geolocation notification prompting was broken and has been fixed in
-    <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1368277">bug 1368277</a></li>
-  <li>A minority of our testers reported a crash when sending or replying to emails starting with SeaMonkey 2.48.
-    This is tracked in <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1308923">bug 1308923</a> and was
-    fixed in <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1364977">bug 1364977</a> for SeaMonkey.
-    The original bug is still open but additional cases are likely caused by add-ons.</li>
-  <li>A crash after archiving messages has been fixed in
-    <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1314347">bug 1314347</a></li>
-</ul>
-</div>
-
 <h2 id="troubleshooting">Troubleshooting</h2>
 <div class="section">
 <ul>
   <li>
     Some questions are asked more frequently than others. Have a look at the <a
     href="https://wiki.mozilla.org/SeaMonkey/FAQ">SeaMonkey FAQ</a>.
     Maybe your particular problem has already been solved.
   </li>
@@ -296,18 +303,20 @@ This list covers some of the fixed issue
     Poorly designed or incompatible extensions can cause problems with
     SeaMonkey, including make it crash, slow down page display, etc.
     If you encounter strange problems relating to parts of SeaMonkey no longer
     working, the browser not starting, windows with strange or distorted
     appearance, degraded performance, etc, you may be suffering from Extension
     or Theme trouble.
     Restart SeaMonkey in Safe Mode. On Windows, start using the "Safe Mode"
     shortcut created in your Start menu or by running
-    <code>seamonkey.exe -safe-mode</code>. On Linux, start with
-    <code>./seamonkey -safe-mode</code> and on Mac&nbsp;OS&nbsp;X, run:
+    <code>seamonkey.exe -safe-mode</code>.
+    On Linux, start with <code>/path-to-seamonkey/seamonkey -safe-mode</code>
+    or first change to the SeaMonkey installation directory and start with
+    <code>./seamonkey -safe-mode</code>, and on Mac&nbsp;OS&nbsp;X, run:
     <p><code>
        cd /Applications/SeaMonkey.app/Contents/MacOS/<br>
        ./seamonkey-bin -safe-mode
     </code></p>
     When started in Safe Mode all extensions are disabled and the Default theme
     is used. Disable the Extension/Theme that is causing trouble and then start
     normally.
   </li>
copy from src/releases/seamonkey2.48/relnote.var
copy to src/releases/seamonkey2.49.1/relnote.var
--- a/src/releases/seamonkey2.48/relnote.var
+++ b/src/releases/seamonkey2.49.1/relnote.var
@@ -1,12 +1,12 @@
-[%- rnote.baseversion = "2.48" -%]
-[%- rnote.basename = "SeaMonkey 2.48" -%]
-[%- rnote.version = "2.48" -%]
-[%- rnote.name = "SeaMonkey 2.48" -%]
-[%- rnote.relativeto.version = "2.46" -%]
-[%- rnote.relativeto.name = "SeaMonkey 2.46" -%]
-[%- rnote.relativeto.stable.version = "2.46" -%]
-[%- rnote.relativeto.stable.name = "SeaMonkey 2.46" -%]
-[%- changes.sm.ver = "248" -%]
-[%- changes.sm.tm = "2.48"-%]
-[%- changes.tb.ver = "51" -%]
-[%- changes.tb.tm = "51.0" -%]
+[%- rnote.baseversion = "2.49.1" -%]
+[%- rnote.basename = "SeaMonkey 2.49.1" -%]
+[%- rnote.version = "2.49.1" -%]
+[%- rnote.name = "SeaMonkey 2.49.1" -%]
+[%- rnote.relativeto.version = "2.48" -%]
+[%- rnote.relativeto.name = "SeaMonkey 2.48" -%]
+[%- rnote.relativeto.stable.version = "2.48" -%]
+[%- rnote.relativeto.stable.name = "SeaMonkey 2.48" -%]
+[%- changes.sm.ver = "249" -%]
+[%- changes.sm.tm = "2.49"-%]
+[%- changes.tb.ver = "52" -%]
+[%- changes.tb.tm = "52.0" -%]