Bug 1435746 - Release notes and website update for SeaMonkey 2.49.2. r=IanN
authorFrank-Rainer Grahl <frgrahl@gmx.net>
Thu, 15 Feb 2018 19:36:27 +0100
changeset 1289 13fbcd9f5088
parent 1288 358a27aa17a1
child 1290 0f58369a583d
push id69
push userfrgrahl@gmx.net
push date2018-02-15 18:39 +0000
reviewersIanN
bugs1435746
Bug 1435746 - Release notes and website update for SeaMonkey 2.49.2. r=IanN
lib/config.tmpl
lib/sitemap.xml
src/news.en.xml
src/releases/2.49.1.en.html
src/releases/2.49.2.en.html
src/releases/index.en.html
src/releases/seamonkey2.49.2/index.en.html
src/releases/seamonkey2.49.2/relnote.var
--- a/lib/config.tmpl
+++ b/lib/config.tmpl
@@ -7,18 +7,18 @@
 [% toplink = "${template.name}"|replace('[^\/]+/','../')|replace('[^\/]*$','') %]
 [% IF toplink == '' %]
   [% toplink = './' %]
 [% END %]
 [% IF template.name == '404.en.html' %]
   [% toplink = '/' %]
 [% END %]
 
-[% releaseversion = '2.49.1' %]
-[% releaserelnoteversion = '2.49.1' %]
+[% releaseversion = '2.49.2' %]
+[% releaserelnoteversion = '2.49.2' %]
 [% releasename = "SeaMonkey $releaseversion" %]
 [% relnotes = "${toplink}releases/seamonkey$releaserelnoteversion/" %]
 [% download_win = "https://download.mozilla.org/?product=seamonkey-$releaseversion&amp;os=win&amp;lang=en-US" %]
 [% download_linux = "https://download.mozilla.org/?product=seamonkey-$releaseversion&amp;os=linux&amp;lang=en-US" %]
 [% download_mac = "https://download.mozilla.org/?product=seamonkey-$releaseversion&amp;os=osx&amp;lang=en-US" %]
 [% download_more = "${toplink}releases/#$releaseversion" %]
 [%# releases.mozilla.org disabled, see bug 871120 %]
 [%# download_allfiles = "http://releases.mozilla.org/pub/seamonkey/releases/$releaseversion/" %]
@@ -27,11 +27,11 @@
 [% download_linux_mb = 45 %]
 [% download_mac_mb = 70 %]
 
 [% betabaseversion = '2.48' %]
 [% betabetaversion = '1' %]
 [% betaversion = "${betabaseversion}b${betabetaversion}" %]
 [% betaname = "SeaMonkey ${betabaseversion} Beta ${betabetaversion}" %]
 
-[% develbaseversion = '2.55' %]
+[% develbaseversion = '2.57' %]
 [% develversion = "${develbaseversion}a1" %]
 [% develdownloadbase = 'https://archive.mozilla.org/pub/seamonkey/nightly/latest-comm-central-trunk' %]
--- a/lib/sitemap.xml
+++ b/lib/sitemap.xml
@@ -8,17 +8,20 @@ http://www.damowmow.com/portal/ (use the
 
 <site title="SeaMonkey Project" url="http://seamonkey-project.org">
 
   <page url="." title="Home" id="home" />
 
   <page url="news" title="News" id="news" />
 
   <page url="releases/" title="Download and Releases" id="releases">
-    <page url="releases/2.49.1" title="2.49.1" id="2.49.1" hide="false">
+    <page url="releases/2.49.2" title="2.49.2" id="2.49.2" hide="false">
+      <page url="releases/seamonkey2.49.2/" title="Release Notes" id="seamonkey2.49.2"/>
+    </page>
+    <page url="releases/2.49.1" title="2.49.1" id="2.49.1" hide="true">
       <page url="releases/seamonkey2.49.1/" title="Release Notes" id="seamonkey2.49.1"/>
     </page>
     <page url="releases/2.48" title="2.48" id="2.48" hide="true">
       <page url="releases/seamonkey2.48/" title="Release Notes" id="seamonkey2.48"/>
     </page>
     <page url="releases/2.48b1" title="2.48 Beta 1" id="2.48b1" hide="true" />
     <page url="releases/2.46" title="2.46" id="2.46" hide="true">
       <page url="releases/seamonkey2.46/" title="Release Notes" id="seamonkey2.46"/>
--- a/src/news.en.xml
+++ b/src/news.en.xml
@@ -1,15 +1,48 @@
 <?xml version="1.0" encoding="UTF-8"?>
 
 <!--
 non-ASCII characters must be DOUBLE-escaped;
 you can use Hixie's converter to get the entity codes
 http://www.damowmow.com/portal/ (use the "Indentify" field)
 -->
+  <entry id="2018-02-15" showfront="true">
+    <headline>SeaMonkey 2.49.2 released</headline>
+    <content type="html" xml:lang="en">
+<![CDATA[<p>
+The SeaMonkey project is proud to present SeaMonkey 2.49.2: The new release of
+the all-in-one Internet suite is
+<a href="http://www.seamonkey-project.org/releases/">available for download
+now</a>! Building on the same Mozilla platform as Firefox 52.6 ESR, it
+delivers those same developments in web technologies such as HTML5, hardware
+acceleration and improved JavaScript speed.
+</p>
+<p>
+SeaMonkey 2.49.2 is available in 20 languages, for Windows, Mac OS X and Linux.
+</p>
+<p>
+<font size="+1" color="#ff0000"><b>Automatic upgrades from previous versions
+are, for most configurations, disabled for this release. If you need to
+upgrade from an earlier version, please download the full installer from the
+downloads section and install SeaMonkey 2.49.2 manually over the previous
+version.</b></font><br>
+</p>
+<p>
+For a more complete list of major changes in SeaMonkey 2.49.2, see the
+<a href=http://www.seamonkey-project.org/releases/seamonkey2.49.2/#new>What's
+New in SeaMonkey 2.49.2</a> section of the
+<a href="http://www.seamonkey-project.org/releases/seamonkey2.49.2/">Release
+Notes</a>, which also contain a list of known issues and answers to frequently
+asked questions. For a more general overview of the SeaMonkey project (and <a
+href="http://www.seamonkey-project.org/doc/screenshots">screen shots</a>!),
+visit <a href="http://www.seamonkey-project.org/">www.seamonkey-project.org</a>.
+</p>]]>
+    </content>
+  </entry>
 
 <newsfeed title="SeaMonkey News" url="http://seamonkey-project.org/news">
   <entry id="2017-11-06" showfront="true">
     <headline>SeaMonkey 2.49.1 download problem solved</headline>
     <content type="html" xml:lang="en">
 <![CDATA[<p>
 We fixed the earlier problem with downloads from the offical server not
 working. Unfortunately we are still unable to enable updates for most
@@ -29,23 +62,16 @@ release of the all-in-one Internet suite
 now</a>! Building on the same Mozilla platform as Firefox 52.4 ESR, it
 delivers those same developments in web technologies such as HTML5, hardware
 acceleration and improved JavaScript speed.
 </p>
 <p>
 SeaMonkey 2.49.1 is available in 20 languages, for Windows, Mac OS X and Linux.
 </p>
 <p>
-<font size="+2" color="#ff0000"><b>Automatic upgrades from previous versions
-are, for most configurations, disabled for this release. If you need to
-upgrade from an earlier version, please download the full installer from the
-downloads section and install SeaMonkey 2.49.1 manually over the previous
-version.</b></font><br>
-</p>
-<p>
 For a more complete list of major changes in SeaMonkey 2.49.1, see the
 <a href=http://www.seamonkey-project.org/releases/seamonkey2.49.1/#new>What's
 New in SeaMonkey 2.49.1</a> section of the
 <a href="http://www.seamonkey-project.org/releases/seamonkey2.49.1/">Release
 Notes</a>, which also contain a list of known issues and answers to frequently
 asked questions. For a more general overview of the SeaMonkey project (and <a
 href="http://www.seamonkey-project.org/doc/screenshots">screen shots</a>!),
 visit <a href="http://www.seamonkey-project.org/">www.seamonkey-project.org</a>.
--- a/src/releases/2.49.1.en.html
+++ b/src/releases/2.49.1.en.html
@@ -1,13 +1,13 @@
 [%- PROCESS release.tmpl -%]
 [%- smversion = '2.49.1' -%]
 [%- prettyversion = '2.49.1' -%]
 [%- relnoteversion = '2.49.1' -%]
-[%- mirrorred = true -%]
+[%- mirrorred = false -%]
 [%- uselongversion = false -%]
 [%- releasedate = "November 4, 2017" -%]
 [%- srcsize = "168" -%]
 <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
 <html lang="en">
 <head>
 
 <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
@@ -19,26 +19,25 @@
 <link rel="up" href="./" title="SeaMonkey Releases">
 
 <title>SeaMonkey [% prettyversion %]</title>
 </head>
 <body>
 <h1><a name="[% smversion %]">SeaMonkey [% prettyversion %]</a></h1>
 <p class="release-date">Released [% releasedate %]</p>
 
-<!-- <div class="important">
+<div class="important">
   <strong class="very-strong shout">Warning!</strong> The SeaMonkey version
   available for download from this page is outdated and may suffer from
   <a href="http://www.mozilla.org/security/known-vulnerabilities/#SeaMonkey">known
   security vulnerabilities</a>. This page is only available for historic
   reference.
   <br>We strongly advise you to download the <a href="./">current release</a>
   instead.
 </div>
--->
 
 <ul class="toc">
   <li><a href="#official">Official Builds</a></li>
   <li><a href="#source">Source Code</a></li>
   <li><a href="#langpacks">Language Packs</a></li>
   <li><a href="#contrib">Contributed builds (other platforms)</a></li>
 </ul>
 
copy from src/releases/2.49.1.en.html
copy to src/releases/2.49.2.en.html
--- a/src/releases/2.49.1.en.html
+++ b/src/releases/2.49.2.en.html
@@ -1,15 +1,15 @@
 [%- PROCESS release.tmpl -%]
-[%- smversion = '2.49.1' -%]
-[%- prettyversion = '2.49.1' -%]
-[%- relnoteversion = '2.49.1' -%]
+[%- smversion = '2.49.2' -%]
+[%- prettyversion = '2.49.2' -%]
+[%- relnoteversion = '2.49.2' -%]
 [%- mirrorred = true -%]
 [%- uselongversion = false -%]
-[%- releasedate = "November 4, 2017" -%]
+[%- releasedate = "February 15, 2018" -%]
 [%- srcsize = "168" -%]
 <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
 <html lang="en">
 <head>
 
 <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
 <meta http-equiv="Content-Language" content="en">
 <meta http-equiv="Content-Style-Type" content="text/css">
@@ -52,20 +52,20 @@
   <li>If you are using NoScript you might encounter a certificate error when trying
   to download SeaMonkey from this site. NoScript tries to force an https
   connection for an http only site. It is not a NoScript problem but how the
   Mozilla server, from which downloads are delivered, is configured.<br>
   In this case please add download.cdn.mozilla.net to the NoScript
   "Never force secure (HTTPS) connections" options or turn off NoScript for this download
   only. The settings are located in the NoScript options under "Advanced->HTTPS".
   </li>
-  <li><font size="+2" color="#ff0000"><b>Automatic upgrades from versions prior
+  <li><font size="+1" color="#ff0000"><b>Automatic upgrades from versions prior
   to 2.48 are, for most configurations, disabled for this release. If you need
   to upgrade from an earlier version, please download the full installer from
-  the downloads section and install SeaMonkey 2.49.1 manually over the previous
+  the downloads section and install SeaMonkey 2.49.2 manually over the previous
   version.</b></font><br>
 
   </li>
 </ul>
 </div>
 
 <h2 id="official">Official builds</h2>
 <div class="section">
--- a/src/releases/index.en.html
+++ b/src/releases/index.en.html
@@ -1,15 +1,15 @@
 [%- PROCESS release.tmpl -%]
 [%- smversion = releaseversion -%]
 [%- prettyversion = smversion -%]
 [%- relnoteversion = releaserelnoteversion -%]
 [%- mirrorred = true -%]
 [%- uselongversion = false -%]
-[%- releasedate = "November 4, 2017" -%]
+[%- releasedate = "February 15, 2018" -%]
 [%- betareleasedate = "April 17, 2017" -%]
 [%- srcsize = "168" -%]
 <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
 <html lang="en">
 <head>
 
 <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
 <meta http-equiv="Content-Language" content="en">
@@ -411,16 +411,17 @@ For some legacy platforms like PPC Mac, 
 support. There are however independent projects that continue to support
 some of these platforms. To learn more, see <a href="legacy">Latest Releases
 for Legacy Platforms</a>.
 </p>
 
 <div class="para" id="old">
   <p>Previously released versions of SeaMonkey:</p>
   <ul class="snav">
+    <li><a href="2.49.1">2.49.1</a></li>
     <li><a href="2.48b1">2.48 Beta 1</a></li>
     <!-- 2.47 was skipped -->
     <li><a href="2.46">2.46</a></li>
     <!-- 2.45 was skipped -->
     <!-- 2.44 was skipped -->
     <!-- 2.43 was skipped -->
     <!-- 2.42 was skipped -->
     <!-- 2.41 was skipped -->
copy from src/releases/seamonkey2.49.1/index.en.html
copy to src/releases/seamonkey2.49.2/index.en.html
--- a/src/releases/seamonkey2.49.1/index.en.html
+++ b/src/releases/seamonkey2.49.2/index.en.html
@@ -17,17 +17,17 @@
 </head>
 <body>
 <h1>[% rnote.basename %]</h1>
 
 <div class="key-point">
 <p>
 <font size="+2" color="#ff0000"><b>Automatic upgrades from previous versions
 are, for most configurations, disabled for this release. Please download the
-full installer from the downloads section and install SeaMonkey 2.49.1 manually
+full installer from the downloads section and install SeaMonkey 2.49.2 manually
 over the previous version.</b></font>
 </p>
 </div>
 
 <div class="key-point">
 <p>The Mozilla backend code SeaMonkey is based on, now usually incorporates
 breaking changes in every release. This is especially true for the Mozilla Gecko
 add-ons code and the JavaScript interpreter. Consequently, some older extensions
@@ -43,17 +43,17 @@ back to a previous version of SeaMonkey.
 <div class="key-point">
 <p>
 For [% rnote.basename %], the following extensions are removed and are not
 included in the distribution (due to repack issues).
 <ul>
   <li><a href="https://addons.mozilla.org/en-US/seamonkey/addon/chatzilla/">Chatzilla</a></li>
   <li><a href="https://addons.mozilla.org/en-US/seamonkey/addon/dom-inspector-6622/">DOM Inspector 2.0.16.1</a>
     DOM Inspector 2.0.16.1 available on the Mozilla Add-Ons page is not
-    compatible with SeaMonkey 2.49.1. You need to use version 2.0.17.0 or
+    compatible with SeaMonkey 2.49.2. You need to use version 2.0.17.0 or
     higher. You can install it from
     <a href="https://archive.mozilla.org/pub/seamonkey/releases/2.49.1/distributed/inspector@mozilla.org.xpi">DOM Inspector 2.0.17.1</a>.
     This version is compatible with SeaMonkey 2.1 to 2.53 and Thunderbird
     4.0 to 56.0.
     </li>
   <li><a href="https://www.mozilla.org/en-US/projects/calendar/">Lightning 5.4</a> </li>
 </ul>
 </p>
@@ -71,62 +71,67 @@ for new information.
 
 <h2 id="new">What's New in [% rnote.basename %]</h2>
 <div class="section">
 <p>
 [% rnote.basename %] contains (among other changes) the following major changes relative to
 <a href="../seamonkey[% rnote.relativeto.version %]/#new">[% rnote.relativeto.name %]</a>:
 </p>
 <p>
-SeaMonkey 2.49.1 uses the same backend as Firefox and contains the listed
-<a href="https://www.mozilla.org/en-US/security/known-vulnerabilities/firefox-esr/#firefoxesr52.4">Firefox 52.4 ESR security fixes</a>.
+SeaMonkey 2.49.2 uses the same backend as Firefox and contains the listed
+<a href="https://www.mozilla.org/en-US/security/known-vulnerabilities/firefox-esr/#firefoxesr52.6">Firefox 52.6 ESR security fixes</a>.
 </p>
 <p>
-SeaMonkey 2.49.1 shares most parts of the mail and news code with Thunderbird. Please read the
-<a href="https://www.thunderbird.net/en-US/thunderbird/52.4.0/releasenotes/">Thunderbird 52.4 ESR release notes</a> for
+SeaMonkey 2.49.2 shares most parts of the mail and news code with Thunderbird.
+Please read the
+<a href="https://www.thunderbird.net/en-US/thunderbird/52.6.0/releasenotes/">Thunderbird 52.6 ESR release notes</a> for
 specific changes and security fixes in this release.
 </p>
 
 <h3>SeaMonkey-specific changes</h3>
 <ul>
-  <li>SeaMonkey should no longer crash when you start it or try to use the mail
-    feature on OS X 10.12 or greater.
-    </li>
-  <li>You were not always prompted for authentication in SeaMonkey 2.48 under
-    certain scenarios resulting in login failures. The problem, tracked in
-    <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1347857">bug 1347857</a>,
-    has been fixed.
-    </li>
-  <li>Mail and News: The way images are included in a compose window has
-    changed. Images are now included as data URIs and not as references to
-    parts of other messages or operating system files. This allows better
-    interoperability with office packages such as MS Office or LibreOffice.
-    Images linked from locations on the internet will no longer be downloaded
-    and attached to the message automatically. This can be changed globally by
-    setting the preference mail.compose.attach_http_images.
-    </li>
-  <li>Language support for nb-NO has been re-added.
+  <li>You were unable to add or edit properties for images and links in the
+    2.49.1 Composer. The problem, tracked in
+    <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1417819">bug 1417819</a>,
+    has been fixed. We are sorry for the inconvenience it caused.
     </li>
   <li>SeaMonkey now uses gtk3 on Linux. If you experience a problem because of
     this please file a bug and link it to
     <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1367257">Switch Linux builds to GTK3 with SeaMonkey 2.49</a>.
     Pleae try another OS theme first. Some of them are buggy and cause problems
     with SeaMonkey, Thunderbird and Firefox.
     </li>
-  <li>Quotes are now colored differently in Mails
-    <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1374708">bug 1374708</a>.
+  <li>With some Linux themes, the menulist- and history-dropmarker didn't show.
+    It was actually there but only 1 pixel wide. The problem, tracked in
+    <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1331208">bug 1331208</a>,
+    has been fixed. As a result the dropmarker in the location bar is now also
+    shown a little wider under Windows.
+    </li>
+  <li>Scrollbars didn't show the buttons under Linux. The problem, tracked in
+    <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1269145">bug 1269145</a>,
+    has been fixed. We will try to improve the visual experience in a follow-up
+    version.
     </li>
-  <li>Under OSX the left panes in Bookmarks Manager, MailNews and Address Book
-    are now styled like finder panes. See
-    <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1095904">bug 1095904</a>.
+  <li>WebRTC has been disabled by default. It needs an add-on to enable it per
+    site. See
+    <a href="https://github.com/IsaacSchemm/webrtc-permissions-ui-toggle"></a>.
+    </li>
+  <li>The active title bar was not visually emphasized under Linux or using the
+    Windows XP/Vista/7 Classic theme. We opted to show it with a striped color
+    bar in
+    <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1398973">bug 1398973</a>.
     </li>
-  <li>Quotes are now colored differently in Mails up to 5 levels deep depending
-    on your OS. See <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1374708">bug 1374708</a>.
-    This may break custom themes for email composition because a new style
-    sheet named &quot;messageQuotes.css&quot; has been added.
+  <li>For security, parts of
+    <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1035091">bug 1035091</a>
+    were ported in
+    <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1411708">bug 1411708</a>.
+    This might cause problems with add-ons like Stylish which use moz-document.
+    Set the pref &quot;layout.css.moz-document.content.enabled&quot; to
+    &quot;true&quot; to overcome this but be aware that this disables the
+    added security fix.
     </li>
 </ul>
 
 </div>
 
 <h2 id="download">Downloading</h2>
 <div class="section">
 The SeaMonkey project provides official versions of [% rnote.name %] for
@@ -209,17 +214,31 @@ Please read this before reporting any ne
     The problem was originally reported against Thunderbird 52 and is tracked in
     <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1356902">bug 1356902</a>.
     As a workaround install the Microsoft Visual Studio 2015 or 2017 redistributable runtime library.
     Official SeaMonkey builds are compiled for x86 so you only need this version
     <a href="https://go.microsoft.com/fwlink/?LinkId=746571">VS2017 x86 runtime</a>.
     The runtime can be installed on any Windows version starting with Windows XP SP3.
     If you already have a VS2015 runtime installed you do not need to upgrade it to a later version.
     </li>
-
+  <li>If you experience a delay showing the first page after start, please
+    delete the Safebrowsing folder in your profile. Bad Safebrowsing data may
+    delay showing the first page for up to 30 seconds. The problem is tracked
+    in <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1432274">bug 1432274</a>.
+    This can occur even if you are not using Safebrowsing because the lists are
+    always fetched.
+    </li>
+  <li>SeaMonkey does not currently support the WebExtensions add-on api. Some
+    popular add-ons like NoScript are no longer shown because of this on
+    the SeaMonkey add-ons website. You can usually get them from the
+    manufacturers site if you can't find them on AMO. This will be addressed
+    when the SeaMonkey and Thunderbird add-ons move to their own site.
+    WebExtensions support is also a planned feature but will likely not appear
+    in 2018.
+    </li>  
   <li>The SSL 3.0 encryption protocol is no longer supported due to
     security concerns (<a
     href="https://bugzilla.mozilla.org/show_bug.cgi?id=1106470">bug
     1106470</a>). Legacy websites may still rely on it and will not work
     with the newer TLS 1.x protocols. Contact the website administrator
     to update their server to resolve the issue at the source.</li>
   <li>The Remember Passwords add-on breaks password handling. Please disable
     or uninstall this add-on using the Add-ons Manager.</li>
copy from src/releases/seamonkey2.49.1/relnote.var
copy to src/releases/seamonkey2.49.2/relnote.var
--- a/src/releases/seamonkey2.49.1/relnote.var
+++ b/src/releases/seamonkey2.49.2/relnote.var
@@ -1,12 +1,12 @@
-[%- rnote.baseversion = "2.49.1" -%]
-[%- rnote.basename = "SeaMonkey 2.49.1" -%]
-[%- rnote.version = "2.49.1" -%]
-[%- rnote.name = "SeaMonkey 2.49.1" -%]
-[%- rnote.relativeto.version = "2.48" -%]
-[%- rnote.relativeto.name = "SeaMonkey 2.48" -%]
-[%- rnote.relativeto.stable.version = "2.48" -%]
-[%- rnote.relativeto.stable.name = "SeaMonkey 2.48" -%]
+[%- rnote.baseversion = "2.49.2" -%]
+[%- rnote.basename = "SeaMonkey 2.49.2" -%]
+[%- rnote.version = "2.49.2" -%]
+[%- rnote.name = "SeaMonkey 2.49.2" -%]
+[%- rnote.relativeto.version = "2.49.1" -%]
+[%- rnote.relativeto.name = "SeaMonkey 2.49.1" -%]
+[%- rnote.relativeto.stable.version = "2.49.1" -%]
+[%- rnote.relativeto.stable.name = "SeaMonkey 2.49.1" -%]
 [%- changes.sm.ver = "249" -%]
 [%- changes.sm.tm = "2.49"-%]
 [%- changes.tb.ver = "52" -%]
 [%- changes.tb.tm = "52.0" -%]