Bug 975034 - Upgrade ec2 test instances mesa versions from 8.0.2-0ubuntu3(32-bit hosts)/8.0.4-0ubuntu0.2(64-bit hosts) to 8.0.4-0ubuntu0.6mozilla1. r=rail
authorArmen Zambrano Gasparnian <armenzg@mozilla.com>
Mon, 10 Mar 2014 09:42:22 -0400
changeset 1468 32b0a9e531f9
parent 1467 2f0052cb6ce2
child 1469 0a59d2cb0149
child 1470 22a53a7ebe82
push id1073
push userarmenzg@mozilla.com
push date2014-03-10 13:42 +0000
reviewersrail
bugs975034
Bug 975034 - Upgrade ec2 test instances mesa versions from 8.0.2-0ubuntu3(32-bit hosts)/8.0.4-0ubuntu0.2(64-bit hosts) to 8.0.4-0ubuntu0.6mozilla1. r=rail
modules/packages/manifests/mesa.pp
modules/packages/manifests/setup.pp
--- a/modules/packages/manifests/mesa.pp
+++ b/modules/packages/manifests/mesa.pp
@@ -6,26 +6,26 @@ class packages::mesa {
         Ubuntu: {
             case $::hardwaremodel {
                 "i686": {
                     package {
                         # This package is a recompiled version of
                         # https://launchpad.net/ubuntu/+source/mesa
                         ["libgl1-mesa-dri", "libgl1-mesa-glx", "libglapi-mesa",
                          "libglu1-mesa","libxatracker1"]:
-                            ensure => '8.0.2-0ubuntu3';
+                            ensure => '8.0.4-0ubuntu0.6mozilla1';
                     }
                 }
                 "x86_64": {
                     package {
                         # This package is a recompiled version of
                         # https://launchpad.net/ubuntu/+source/mesa
                         ["libgl1-mesa-dri", "libgl1-mesa-glx", "libglapi-mesa",
                          "libglu1-mesa","libxatracker1"]:
-                            ensure => '8.0.4-0ubuntu0.2';
+                            ensure => '8.0.4-0ubuntu0.6mozilla1';
                     }
                 }
             }
         }
         default: {
             fail("cannot install on $::operatingsystem")
         }
     }
--- a/modules/packages/manifests/setup.pp
+++ b/modules/packages/manifests/setup.pp
@@ -53,17 +53,17 @@ class packages::setup {
                     url_path => "repos/yum/mirrors/passenger/rhel/$majorver/latest/$architecture";
 
                 "hp-proliantsupportpack":
                     url_path => "repos/yum/mirrors/hp/proliantsupportpack/CentOS/$majorver/$architecture/current";
             }
 
             # to flush the metadata cache, increase this value by one (or
             # anything, really, just change it).
-            $repoflag = 13
+            $repoflag = 14
             file {
                 "/etc/.repo-flag":
                     content =>
                     "# see \$repoflag in modules/packages/manifests/setup.pp\n$repoflag\n",
                     notify => Exec['yum-clean-expire-cache'];
             }
             exec {
                 yum-clean-expire-cache: